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1  QuestaSim Visualizer Debug Environment 27|

QuestaSim 2023.1 {2 E Visualizer Debug Environment X|&0| Z&H&| & LICH
QuestaSim Visualizer Debug Environment £ QuestaSim 0| A &2 O|O|E{ & Visualizer GUI 2 @1,

Visualizer 2| CtY¥35H Advanced CIHZ 7|52 &3l CIXIQI2 A 24stn CHAdE = A= Tool YLILCE

QuestaSim Classic QuestaSim Visualizer

driver/receiver tracing from
wave and source code

browse design by hierarchy,
objects and source code
schematics with smart
: FSM debug & cross probing hierarchical flattening
= - - f

ross probe with waveforms

e ——— J——

design search by type —a

Dataflow Window

List Window

with cross probing & biometric search

schematic exploration with smart pruning

Limited offline debug Full offline debugging




QuestaSim Visualizer & 7|Z£2| QuestaSim Classic Of |3l A|E2]|0|M 450 2 HY W20, YO0|EE H|O|EHE
XEe oz 34 ojA M2 82 XZEHELICE o|z{pt EF HEo| C|lAd S7HE EUYSIHNM T 2
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2 QuestaSim Visualizer Debug Environment &% 4+t

QuestaSim Visualizer = 2 7tA| ZER &S 5 USL|CE

2 7}X| EE£ QuestaSim 2| 3-Step Flow(Compilation, Optimization, Simulation) 2 A2 %L|CH

0| I, Optimization TtA2} Simulation THA 0| A= QuestaSim Visualizer @ &1} H =l mtAUZ WM5t=
SH0| =0 ASLCH

2.1 Post-Simulation 2E

post-sim ZE= A|Z2|0|H 2tE El Design Information It 21t Simulation(waveform) Database It 2
QuestaSim Visualizer GUI 2 SO{M C|XIQIS BEMstD C|HAE = AUSL|Ct
Ch A2 0| ZIo] 22 E|A7|0f| breakpoints, restart, run BES AFEE 4= Q& LCH

1-Step  (Compilation: Compile Verilog/VHDL rtl files with vlog/vcom command)
vlog <verilog_rtl>.v

vcom <vhdl_rtl>.vhd

2-Step  (Optimization: Optimize design with vopt command for debuggability)
vopt <design_top_name> -0 <optimized_name> -debug -designfile design.bin

3-Step  (Simulation: Run Simulation with options for gwave dump)

vsim -c <optimized_name> -do “run -all; quit -f* -qwavedb=+signal+memory+wavefile=qwave.db

4-Step  (Invoking Visualizer)

vis design.bin gwave.db

ZM HE2 “QuestaSim Visualizer 2| Post-sim / live-sim §M” @52 &1 FA|7| HHZL|C}



2.2 Live-Simulation 2. E

live-sim ZE+= 7|& QuestaSim Classic 2| A3 ghAlat H|==8CtD & = Y&L|CH
59

Z, QuestaSim Visualizer GUI 2 E11LtA breakpoints, restart, run
1-Step  (Compilation: Compile Verilog/VHDL rtl files with vlog/vcom command)
vlog <verilog_rtl>.v

vcom <vhdl_rtl>.vhd

2-Step  (Optimization: Optimize design with vopt command for debuggability)

vopt <design_top_name> -o <optimized_name> -debug,livesim -designfile design.bin

3-Step  (Simulation: Run Simulation with options for qwave dump)

vsim -visualizer=design.bin <optimized_name> -qwavedb=+signal+memory+wavefile=qwave.db

=M HdHL2 “QuestaSim Visualizer 2| Post-sim / live-sim 4" &58 £t1038|| FA[7| BHEEL|CH



3 QuestaSim Visualizer 2| Post-Sim / Live-Sim &4

[= I
vopt options
-0 <optimized name>

: Design Top Ofl Ci$t <optimized name>O|2t= 0| 52| %

-debug

: Post-sim 2 E0A CIHZ S 2o AFELIC.

-debug, livesim

: live-sim 2EO|AM CIHAS

@I%t breakpoint, restart 2| 7|5& &d2t5t7| s A+EE LITH

-designfile design.bin
- Visualizer Tool | A AME S C|XIQI HE mt A (design.bin)2 ML Lt
Ol mU2 CiHH Al Hast HEE Eé‘éh_‘— ASLICH
vsim options
-c
: command-line ZEO|A A Z80|HE HEMSI=E X|FTtLICE,
-do
"<command_string>" 0l X| & BHES +ASIHLI 52 DO TS HASt=E XAl LT
-visualizer=design.bin
: live-sim 220X Visualizer & A% I AtREL|CE
O| m, C|XtQl ‘8 & ot (design.bin)= ZEHA|F Visualizer & = ZETL|LCL
-qwavedb

: Simulation(Waveform) DB It 245t
Ol M2 Ct3at &2 7 &4
+signal
+memory

+wavefile=qwave.db

vis(=visualizer)

:vis 22 visualizer 3ES 9™

oco=

H5L0] Visualizer Debug Environment & @& 2fLILCT,
O| I, Optimization I Simulation TFAI0A 44 El design.bin, qwave.db IS X|F5I0| =
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4 Waveform Database(qwave.db) It 2 QuestaSim Visualizer 285}

QuestaSim Visualizer = C|AtQ! D} O|L} 2 Y 20| E 2|2t 2tA §10] Waveform H|O[E Tt & ==
U= wave view ZEE HSELICH 0| REE AFESHH IPLE 2 C|XIQ MU 2 ZosHK| e

AlEgold Z1E A S7E + UASLICL

A HXt= Cra21a 25U EE
1. Waveform Database I & (qwave.db) 4 4:

e 2.1 Z Post-Simulation 2 E=2| X|&0f| 2t qwave.db It S g L|Ct.

2. QuestaSim Visualizer Ol Al wave view 2 E Al3H:

e CLlI: visualizer -wavefile wavefile (0| visualizer -wavefile qwave.db)

-

L

e GUI: QuestaSim Visualizer & ¢t O|+52| File > Load Design... = 228 LICH
d

=
%+0| LIEFLIEH, Load Wave File 220]| oty nj S MEHSIT load HES Z2/THLIC

=

B Load Design ? x
Load Design File

v Include Design File

Design File: - Browse...
Load Wave File

V| Include Wave File

Wave File: rials/verilog/basicSimulation/gwave.db | ~ | | Browse...
Load UCDB File

V! Include UCDB File

UCDB File: v Browse...
Options: -

Load Cancel

wave view ZEE AMSIH CHZ0F 22 window TF EA|E L|CH

° H H WV Visusiizar - 20241 - G x
DeSIgn WlndOW File Edit View Tools Window Help
. . « = BHEE » 2 0 A CMwem -|47 s~
L] Va”ables W|ndOW |m Design - test_counter HEAE & Variables - test_counter AR
# Bt4 Show: Al, BB AFO -/ & F Filler v =) &
. test_counter ~|[=]pu Name Type Value
*  Wave window )
- ST =st_counier dut scope
o dut counter reset reg
Wavel
File Edit View Options Toals Window
rw G LREAHHHNN d 2R FAF (C. (47 :|l e 137 : Difo0lns - Freqlllll » W.» F» P»
4 SignalName ValuesC1 0 5 300 330 400 450

Transcript £ WaveQ - Current E3

test_counterdut Time Range: 500




5 Visualizer ZM 7|5 Al wH

Visualizer = 24X 2E& C|AtQl W20 A EHO{Lt
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51 Z}Zt2| Window LHOM HA 7|5 AME YH

Visualizer Off /= CHE

=2| Window O|AM= AT = QU
HM 7|52 A8t B

2 Chga Z2&L

o Q! 450l A Edit>find & MEHSLICE.

—
«  J|2E0|M Ctrl+F E F&LICHL
5 Find 7 X
Find What: | | # | Find Next
Match Case Search direction Close
Whole Word Up @ Down
Regular Expression

Mt A2 Tt E YT CHS Enter € 52711t Find Next HES S &/ 2L Ct
QUdtE O 2 A}

&&= Window = L2t Z& L.

Source Window / Transcript Window / Message Viewer Window

U= Window = Of2{Qf ZH2 =71 M

Z aM 7158 MSLICH

Find Strip 7|&

Find Strip £ SAS7F EAUHZ LGS 22| 715 PEEY EASIE Window 0N S ELIEE
0] 7|52 Window SHEHO| LIEFLID], Z4stei EHojE @ T O|HO| A E ol 2
2 4+ 9t EEOR 220

-

HII

=L

Find: | dut

v ¥y | x

clk
reg

' parameter
bit

GHSD 4 OIS WA 8 Enter 8 £E U
UgHo 2 ALBE e

Locals Window / Files Window / Variables Window

Classes Window / Class Instances Window / Sequence Window



filter Strip 7|5

filter Strip 2 Window 22| tHO]E EH 2(J}st= LETH H7))3}7| 5 AH&E LTt
= SH C
— AN

Ze|Yotelt £Hol2 Y2yt

' Variables - top.dutAl

Show: All | B* B%® A: None ~ & F  Filter: CLK - || .
Name Type Value E]QHE—COUNT
4 CLK input wire BYTE
fast_clk reg
» CLK_count int
» fast CLK_count int
seti_clk logic

Design, Schematic, Wave Windows = CHE &4lo2 AM 7|52 HSELIC
5.2 Search Design Window O|A ZAM 7|5 ALS 4

070l A View>Search Design & 41E#S7H L} Ctrl+Shift+A £t 7| = Search Design Window £

¥ & YL,

. . ._ L o .
Search Design Window O A= Module £+ Scope £ MEHSIO] S| CIXQ! LHOJ Al &t A2
= S A A H i = =+ < o - o T AIS
HHOlE MY 4= AS UL Filter 20| HO{S Y=OHH, sliE FHO{QF XS Zat2ts BAIE
A A
T UASLICH
B search Design - m] X
Search Design )]
‘¢, Module ) Scope |dut ~|u" & [&@ |Object Types...
Filter:[always -] .
Name “ Module Name  Type Line  Count Description Scope
always dut Always 42 4 always top.dutAl,...
always dut Always 77 4 always top.dutAl,...
always dut Always 80 4 always top.dutAl,...
always dut Always 92 4 always top.dutAl,...
always dut Always 154 4 always top.dutAl,...
always dut Always 192 4 always top.dutAl,...
always dut Always 223 4 always top.dutAl,...
always dut Always 277 4 always top.dutAl,...
always dut Always 283 4 always top.dutAl,...
always dut Always 330 4 always top.dutAl,...
always dut Always 335 4 always top.dutAl,...
always dut Always 340 4 always top.dutAl,...
always dut Always 345 4 always top.dutAl,...
always dut Always 351 4 always top.dutAl,...
always dut Always 357 4 always top.dutAl,...
always dut Always 363 4 always top.dutAl,...
always dut Always 370 4 always top.dutAl,...
always dut Always 375 4 always top.dutAl,...
always dut Always 379 4 always top.dutAl,...
always_latch dut NoSRLatch 192 4 Latch top.dutAl,...
always_latch dut NoSRLaich 283 4 Latch top.dutAl,...
always_latch dut NoSRLatch 330 4 Latch top.dutAl,...
always_latch dut NoSRLaich 335 4 Latch top.dutAl,...
always_latch dut NoSRLaich 340 4 Latch top.dutAl,...
always_latch dut NoSRLaich 370 4 Latch top.dutAl,...
4 »
. Search View Ready




o= C o| - ES A2 ko) AlO OG22 EHS
f5 oo A= Object Types... HES ZE5IH, O XtM3] 21 A2 RS MELSHO]
o St A Ol
ZEHEY & ASLICL
B Object Types ? X
Variable Type Statement Type Inferred Type

All None All None All None

Alias Vv Always ACB

Block Analog Device Instance FSMm

Class Definition Architecture Flop

Class Variable Blocking V| Laich

Clocking Block Case MUX

Data Member Delay No SR Flop

Function Fork No SR Laich

Interface Initial

MSNet Instance

Memory Instance (BE)

Module Instance (PA)

NamedEvent Loop

Package Non-Blocking

Parameter Process

Port SVA

Program System Task Call

Property Declaration Task Call

eal

Scope

Sequence Declaration

Struct Definition

Struct Definition (Packed)

Struct Variable

Struct Variable (Packed)

Task

Variable

OK Cancel Apply

5.3

|40l A View>Search Files © A EH
USLICH

Search Files Window O|A| Al 7|5 AL HitH

7L} Ctrl+Shift+F EH=

7|2 Search Files Window £

H . = < = 17 (o] - = S A A
Search Files Window & &3l, 2= LM 2St= HAES AMY & UAESLICH
= kel © = S o =X I =
it 2440 dof EAIZH, DY /K|, & He 22 7 YEE e 2o ELICH
— 77 = O|ALL = SE A
Search Files Window Ol M= It L& & Adt= HAEES ZI0I CHE HAEZ LXg £
& Search Files = o X
Search Files £
mem © Aa {8 (9 € O Design ~ - A
Replace Replace |Replace Al v
Maich Line e =
&.| Filter (Text) ~ J|_=.|Filter (Number) |~ =
~ C:/Users/EDNC-SYKIMAvisualizer-examples/simple-sequences_postsim/fism-seti.sv f
data = mem(offset]; 715 )
ref logic [31:0] mem[0:'hfff], 694
+ C:/Users/EDNC-SYKIMvisualizer-¢ imple-sequences_postsim/dut.sv
value = mem([addr]; 487
value = mem[addr]; 467
addr, addr, mem[addr], mem[addr]); 442
addr, addr, mem[addr], mem[addr]); 442
mem(addi] = data; 439
mem{[addr] = (data<<8) | (data_rot13); 437
I/ mem[addr] = (data<<8) | (daia_rot13&8'hff); 435
addr, addr, mem[addr], mem[addr]); 409
addr, addr, mem[addr], mem[addr]); 409
mem(addi] = data; 405
mem{[addr] —(dala«B) | (data_rot13); 403
DATAQO = mem[addr]; 385
mem, 308
logic [31:0] mem([0:'hfff]; # Only 100-1000 are legal 38
~ C:/Users/EDNC-SYKIM#visualizer-examples/simple-sequences_postsim/cube5x5.sv
Sdisplay("%m: mem([%0d][%0d] = %0d", i, j, mem[i][]); 122
Sdisplay("%m: mem3[%0d]%0d][%0d] = %0d", i, J, k, mem[[k); 114
mem[i][j] = 79
meml[i][j] = x 76
mem{i][] = (i*5)+; 73
meml[i][] = '0; 70
logic [7:0] mem [0:4][0:4]; 32
{flogic [7:0] mem[5][S]; 31
~ C:/questasim64_2024.1/verilog_srcfuvm-1.1d/srcireg/uvm_reg_map.svh
uvm_mem mem = mem_; 1625
uvm_mem mem = mem_; 1625
foreach (m_mems mlD[memJ) begin 1624 -
11000 Resuilts in 29 Files
.

=

i



6 3 UHMAE 37| TH Wy
QuestaSim Visualizer | A 2tH 8! HIAE F 7|5 2 H-S= WY 2 O30t 25U
1. Edit Ol Of A Preference (Ctrl-N) S 1 EefL{LCY.
General > Font & MEist =, Font / Font Style / Size & M™% £ U&L|CH
Preferences Manager x
F Application Font | Liberation Sans 14
S General ' || AaBbCCDAEEFIGHNIJIKKLIMMNNOOPPQARISSTIUUVYWWXXYYZZ
Coloi The quick brown fox jumps over the lazy dog!
ATV Window Font Liberation Sans 14
Breakpoints AaBbCcDdEeFfGgHhIiJjKk Select Font X
Browse Menu The quick brown fox jumps -
Bold 14
Classes AaBbCcDdEeFfGgHhliJjKk
# Default The quick brown fox jumps {|Khmer OS = 9 al
Dgsign ) Monospace Font Khmer OS Content Regular 10
& Driver Receiver Khmer OS System Italic 1
Event Order AaBbCCDAEeFTGGHNILITH, iheation Mono Bold ltalic 12
— | The quick brown fox ]
& FSM =)
® Files 16 -
LiveSim
@ Locals Eﬂel;:tsd » Sample
@ MSNet =neerine AaBbYyZz
Memory Usage
# Message Viewer
PopupSearch @ Cancel
Schematic L :
Search Design <
& Search Files <=~ Reset ® Cancel #0OK
2. WM &P 9 HAEO| 37| RHI UK} S B, Ctrl 7|9} + i - 7|5 2
gL O|E S A 2t 27|15 &AH =2 &+ UASLICL
3. S HoIMT sjB 9 MAEO| 37|18 ZHIAK St B, Ctrl 72t 0 EE 97|
=20 gL|Ct 0| E Sl X g d=tel g2 A7|2s =2 = AsHCh
O| &7 QuestaSim Visualizer = AL&Ate] HO|E Qo ot E Sl HAE 37| =2 7|52 MS5t2
UAELILE O] 7|5S &8I HYS HIf HE|SHH Tl = ASLCh
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7 Wave Window - Radix S} HitH

Wave Window O|AM= £ Al50f Radix & st 4= USL|CH

1.

Wave Window 2| Signal Name Z0|A Ct2& S22 Radix & 2 M2 E MEIY

gl oo
o QITESIA| 2 oy Mz dE
. o) A ofo SO0 o O ANE S = O =351 S =2 ==
D LIEHS| LHEEX| B2 M=ol 4%, 0L E M= 0| fl2 0|&¢e = Cirl 7| & =8
=2z|8 S S o s
SENOIA SEgLCt 2 A=0f tish of ugE gh=gLch
2K rSskel S El
o &Moo= QIS o M MEH
. 5 (o] o| > o S22 32l = =
D LIES| RO Rle A=l 2, A B M= & SE o £ shift 7§ +&
u] SE 32lG S
SEfOI A OFX|8 M2 S St ML T
= S E
e BE Mz MEM
. Do =gl S L o
AT O|EE 28It 2 Ctrl+A 7| & F27{L}, Edit > Select All & MEHBEL|CE
> o A = E HE2I5 & 9|3l (ofer K=X EHS
2. MeEist AS0| Cf3f 0124 QEZ HES 2% &, Yle Radix RHS MEL0f
SICHSH o S M v = SCSE A A
I ELICE Radix #EEZ H=7|7F 2850 O] B2H Radix & 2L = AL
Signal Name COPY SPECT ’
= Paste
Delete
Remove Al : \
Add Comment Row...
Add Spacer Alt+A
Add Message Row
Binary
Representation Decimal
Wave Display | v Hex
Wave Draw » Mnemonic
Wave Height v Octal
Find Wave Point ’ String
Group... Shift+G Strength
Ungroup Alt+Shift+G Load Custom Radix...
S H = SH & A n Sk A S
EESh Edit>Preferences & &3l 2td 27 2t2| X0 A Default Radix & HEY = A2 H, &
i (e iy MX (0] =S
Radix 7} Values €O0f| BA|E| =& MA™ESIAHL} SHAE 4= &L
& Preferences Manager 5 X
Find: ~ # & 1t Vv Show Descriptions
= is true, =
| General | otherwise the operation will be disabled
Eo’g v Display the current context in window title bars
N ATVO S Windows that follow the current context will display that context in their {
» Breakpoints Display the path(s) to the wavefile(s) in the Main Window Title Bar
» Browse Menu This may be useful if you have multiple instances of the tool running
i
:(C:;sssllancsﬁance Default Radix  Mnemonic  ~
> gl(‘?:ss;aslm Debug Selects the default radix for display of values
Debuglog V' Display Size and Radix with Value
» Default Display size and radix with values if true
» Design Display Leading Zeros (Hex and Octal)
: E;';ﬁ{g’%c:"ve' Display leading zeros in hex and octal values if true
» 2000 Progress Delay (ms)
» Files The amount of time that must pass before a progress dialog appears
b Eﬁjwng\:‘a‘gga“" 0 Bin "_" Separator Spacing
LiveSm? Binary numbers will contain underscores every N digits
» Locals 0 Dec "_" Separator Spacing
» MSNet Decimal numbers will contain underscores every N digits
lylideon A 0 Hex"_" Separator Spacing
» Property Analyzer Hexadecimal numbers will contain underscores every N digits
» Schematic 0 Oct"_" Separator Spacing
» Search Design Nrtal numhare will contain undarernrac avan: N dinite &
» Search Files $ >
» Sequence
N §xgnal qmboard = Reset OK Cancel

oz EY M3l Radix & A ¥ 4+ JUE&LICH
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8 Wave Window - 15 X% 9l 2 C HitH

Wave Window O M= 2= M=l dEish {0 s S5 Mo, e 55 TS LA
£ £ UASUCE Visualizer = 7| 2HOZ CI21} 242 EAMS HEH10] do THYUE ASE

ISESEEs

: Zoom Level, Pan Position, Pane and Grid Markers, Nested Groups, Background Color,
Foreground Color, Signal Height, Radix Settings, Markers, Grids, Groups

Signal List T} Y& XZEsH= 22 ofajet Z&LCt.

1. Wave Window Of 213 & F7tgtL|C}

2. Wave Window 0ff = BE A2 E NYSIX| e MEE A E MEASL|CE

3. MEist M ME) MEist MS S XZESt2H File > Save Selected Signal List £ M EistL|C},
4, BEMT NHF) BE MSE XMESIZ{H File > Save Signal List(Ctrl+S) & MEitL|Ct,

5. Save Signal List File T2t & XH7F H2|H, do AR IS M LC

MEE Signal List THYS 2ESH= 2 of2f et 2 Lot
1. 8l Wave Window & @L|C}.
2. File > Load Signal List & ME#5}0f Read Signal List File TS} & XHE EL|Ct,
3. ¥ot= do WUS MEATILICE

AlZF Al Signal List ItY2 EESH= &R2 of2fet Z&LCt

1. HOZ oM L3 BB S YLD

o o=

visualizer -designfile <design_filename> -wavefile <wave_filename> -do <signal_ filename>.do

Of $YOZ Signal List TrA S & MEste =212 & AFHCH

12



9 Wave Window - Search 7|5 A2 i

Wave Window 0| A{

=
—_
= SE A A
QIABIAZ AME & UHLICH

d wave signal 2| transition 12|11 X[ El transition 2] &

9.1 Finding Signals by Name

Source Window Of| A 0|0] 2EE M E AMg = QI&L|C}

A4M L2 Chg 25 L

1. Source Window 0| A HM3t2{= 412 0|F2 OIRA RER HELE SE[/5t4 Highlight

In Wave £ MEHBEL|LCY,

eg fast clk:
1'he B Add to Wave Clrl+wW
. ¥ Add 10 Wave...
always begin o
#10; fast | B Add to List Ctrl+T

1°he | B Add to Event Order

#10; fast_| @ Add 1o Waich
1'he

end £ Show Drivers cl+D
© Show Receivers Cirl+R
int CLK_coun g
32'hooBo)
int fast CLK B Show Logic Cone Cirl+Shift+K
22" hoooo & Show Time Cone
- Show Trace X
i {V."'ﬂ £ Go To Current Context

logic [31:0] Call Stack

logic [31:0] g aqdipelete Bkpt On Change

#, Show Property Analyzer Crrl+4
logic [B:0] 1§ copy cul+C
&, Copy Full Hierarchy Path Ctrl+H
logic [7:0] | [ Edit Source (dutsv) Cirl+E
Copy Source File Path
logic [E}Tiv: Save As. Clrl+Alt+S
logic co; Gotwo
1'ho Search for Value...
bit secure h &% Find.. Curl+F
1'he # Force

. & Slice Operation...

VORRESY i o viove ——Shifon ]
Simple Selection Mode Ah+Shift+S

B fsm-selisv | o window

2. AEHSE MZ = Wave Window Of 5t0[2t0|E HA|E L|C}.

Top. dutAZ

9.2 Searching for Transitions

Wave Window O|A= 7HE M= 9| transition 2 A = A 20, Single transition EE= Multiple
transition & MEHSIO] TS 4 UL LT,

Single transition & AA3st= W2 Lt 25U
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1. Waveform EOlA signal transition 2 22510 A A[ZSte = AlE2|0[H AlZHO|
712 HME 2 O3, M2 0|2 014 QEZ HECE 851 Search Selected
Signal...(Ctrl+Shift+F) 2 t Wt LI Ct.

Add Spacer Alt+A

Add Message Row Alt+M

Radix

Representation

Wave Display

Wave Draw

Wave Height

Find Wave Point

Group... Shift+G

Ungroup Alt+Shift+G
2 Add to List Ctrl+T
A Add to Event Order
/* Force

Transactions
Compare
Expression
Annotate
Search Selected Signal...
Count Events...

Grid Events..

2. Search Selected Signal &0{A{ Value transition from: & To: ZE=0f gt Y&HTtL(CE
X

B8 Search Selected Signal ?

Value transition from: * - To:\

Previous Next Close

3.  Previous £ Next £ 28519 tran5|t|on Rt L|CE

B Search Selected Signal

Value transition from: * ~| To: - v RegEx Nth: 1

Previous Next Close

Multiple transitions & AMots Y82 ChE0t Z5 L C

1. Waveform &0 AlS O|EE OI1RA 22
MedshL|C},

B
=
rjm
o)
tu
ulu
Ju
O

1 Grid Events...&

Ungroup Alt+Shift+G
8 Add to List Ctrl+T
2 Add to Event Order
# Force

Transactions

Compare

Expression

Annotate »
o &£ Search Selected Signal... Ctrl+Shift+F
Count Events...

Grid Events...

Sort

Properties

2. Grid Events &0| &2|H CtZ2 ALt
e Grid Source X EH
e Value Transition X| &

«  Time Settings &l

14



E Grid Events
Grid Source

e Selected Signal Custom Grid

Value Transition

From: * *| To: |* - RegEx Nth: |1 :
Time Settings

Range: | Simulation ~ | 0 */| ¥./|1306314 |7 ¥,
Interval:

|Add Grid| Remove Grid | Close

3. Add Grid HES 2&2ISL|CL (Grid Events = S1X| MM =l Wave OBt 1Q8kL|CH)

E Grid Events

Grid Source

e Selected Signal Custom Grid

Value Transition

From: |* - To: |B - RegEx Nth: |1 :
Time Settings

Range: Simulation ~ |0 2 w_| 1306314 [1|| ¥.
Interval:

|Add Grid| [Remove Grid | Close

EXH transition & ZASIH 7|2 HAM I} A transition 22 O| S &|0H, Af transition O] S XY
%

.|
o
ClAZ20] $0) 2AOB Wave HO| AHS 22 AAZE|0f 34T transition O] S0 FAIFLITH

.dutA2.
top.dutA;
top.dutA:
top.dutA;
top.dutA:

top.dutAz. 1
top.dutA2. 1
top.
top.

15



9.3 Biometric Search for Multiple Signal Values
Wave Window Ol M= 2= MDO|AM X|ZE gte| E& QAEHAE HMSID AR = JUSL O

*f%XWF OlHsH IS

J MSE W Rop AL ME F7HE ASE AHE0R Z M)

2 7
HAISIO] Alg22|o|d & §F 42 MUEsH FHS D fajg = ASH Lt

Biometric Search 2785l= W2 Or2fot Z&LCt.

Ju
Ot
_9_

1. HMStElE 22 THBHE signal transition & 2 HME Shg 9Kl =

Wave Window Ol A{ Tools > Biometric Search.. (Alt+B) & *.JE 5l 0§ Biometric Search 78%
=Lt

Wavel - Current

File Edit View Options JfelslS| Window

v~ C9O @@ Quick Marker Ctrl+M

Signal Name New Marker...

™ Manage Markers... Shift+M
|« Manage Bookmarks... Ctrl+Shift+K

Biometric Search...

== <4 X :t:} |AlSignals -
Next

Prev
Add
Edit

Delete

Close

Disable All

2. AddHEZ 2

= = =1510] Wave Search && EH, &S signal transition 40| Search Value
2L Ats2 g1

=1
2
2 Q2E|n, WRo| W2t CHE 8 YR & YsLC

B8 Wave Search ? x

Search Value: |zz |[Aa| 4 |%)

B Color Glitch Sequence Disable
Ok Cancel

3. Color A2 22s0) ZME 22 EAIZ M2 MeysiL|Th

16



4. Ok HIEE 2&dl0] S 2AF3IH, Biometric Search &0l X783t AA Z{0| EA|ELICH

?

X

E Biometric Search

&= 4 X it:ij AlSignas -
v lzz Next
Prev
Add
Edit

Delete

Close |

Disable All

5. Next = Prev H{ES 22/5t0] MEfBH Zto| Ctg i
ol 7|2 HA7t ST 3ol CH Ei= O
HAIS|H, A|23[0|4 A|ZHO| GUI HH 0| A 60| EEL]CH,
Values C1 [©

¥  Signal Name

rt_transactor.
uart_tr
uart_tra
uart_transactor

6. A= US EF & Biometric Search & & E&L|CH
0| 7|s2 &ofl, XI'dt 442 ZE QAAEHAT} MEASE MMOZ HA|L|H, Waveform &2 FA6IH
RIHE 30| QAHAEO| 2 MO HA|Z|1, O|HH HAIE MES S8 Waveform O M X|HE
20| 2B IXIE HA AT 4+ YL
Values c1 | 100000000 140000000

uart_
uart_tra
uart_t

17



10 Wave Window - Marker 7|5 Al dhH

Wave Window 0| A= Marker & 4°dslf X (A= 0| AlZhel EF X E XEStD 20|52

XN™E 5= JUSLLCEH Marker = & AHXZE AT ESE D™E X0 &0F A0 MZESH /X2
A Sotd £ A2, B E Marker = M=l Wave Window 0|2t ME2L|H CtE &0z ZREX|
OF A |_| |:|.

=]

10.1 Adding A Wave Window Marker

Wave Window Al Manage Markers HES AFE3}0] £ O

S g
O| H++0AM waveform marker & BiX|St0 HEZ = JQESLICH W,

1. Signal waveform O A &35}= transition 2| 7t AIE[E H22{B Itd HA|E =82 =
23 ESLCL
2. oiF transition & SEISIH WP AlE2]|0[H A|ZH| 7|2 FHAM(C1)7F X =0f| HiX|E L|Ct.
3. IOl marker & F7t5t= W2 Ch21at 25 L(TL
o C1 2o A} HXI0 Quick Marker(Z|& &7 AtE) F7H= otzfe| B & StLt=E

st FLcot

- Ctrl+M & &L CL

- Manage Markers HEZ S &5t Quick Marker & &S| T}

L ¥ - R P

Quick Marker
New Marker...

Manage Markers...

Goto
Goto Test
o AR Mo A™ES AFEX HolE 4= U= New Marker £ F7t5t= W2 CH3ot
#sLcot

1. Manage Markers HES 22511 New Marker & MEHSIH, Add Marker
ol = E L.

|ET| '!' » T v A
Quick Marker Ctrl+M

Manage Markers...
Goto |

BB Add Marker ? *

Name: Markerl
Time: 1208200 |- Unit: |ns -~ ||l Color

o Ok Cancel
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2. Name EEO0| Marker 0| B2 2 X|g3dte{= =AE YHYLICHSH Y E
Z

22X} &L, o: Marker + 1). A|ZH & tt|o| 7| =32t
S| XL Ct,
3. (ME AtEh 7| 20IAM AlZE BHR| EEE MAN| CHe B2 BHEeL| O}

4. Ok HEZ 25, OfEH-‘Ef 7*OI S AXIO Marker 7+ BiX| & L CF.

1"t IR O OO O OO O O AR AR R AR R
1208200

4. (M= AFE 7IE Marker o 2HE HZHRLICH

1. Marker label (0l: Marker1) 2 5

H S E5IH, Chx =50 CHsh Chet 442
X ™t = U= Edit Marker 0] S &IL|CH
B dit Marker 7 X

Name: Markerl
Time: 1208200 || Unit: [ns - ||H Color
f | Delete | Ok | Cancel

«  Name (7|22 Marker1)

¢ Time (7|2X2oZE 0| 2 7|2 AHAML| {IX[LICt)

s Color (Select Color 0| 2|1 Y EOM MyS MESIHLE RGB E=
ol
AN

16 = 242 XIF5HH Marker M2 X8 =
2. Ok E ZE5IH Edit Marker F0| B3| HE Ateto] HEE LT}

5. IHEO|M CHE AlE0|M AZtS SE6HH AHM X[7} £ E O|SstH, HME
0| S8l = Marker @ label 2 X|HEl QX|0f A= SX| = L|C}

Marker & F7t5tH Waveform &2l X|"JEl A|Z2|0|M A[Ztof =& M0| EA|Z|H, siT 20|52
g OfThof| LtEfLER 7|2 MO 2 0{2f Marker O| 3[0|S2 & SITHOl| T A2 HAIELCE

19



CtS @22 Preferences Manager 0| Al 7|2 ™S

= HEg & AFH L

*  Display Marker, Event Labels at Top of Window

-0l gMg M

— 2} Marker label &

I Marker labels 7} It HEA S
«  Display Marker, Event Labels in one row (7|28 2= {Ei
HLo| Ao EAISIAEH O FHS I FATLCH

£ Preferences Manager

Find:

Startup

- # 4 1 v Show Descriptions

> Flow. Nevi Display Marker, Event Labels at Top of Window
oW Nevigator Display Marker and Event Labels at Top of Window if true,
Launchpad bottom of the window if false
LiveSim - ! -
» Locals v Display Marker, Event Labels in one row
» MSNet Display Marker and Event Labels in one row
» Memory Usage v Display Input, Output and InOut Port Icons
» Message Viewer Display icons for ports in the name column if true
» Property Analyzer Auto G c
» Schematic uto Group Create
» Search Design Automatically create an empty group at the bottom of the
» Search Files signal list if true
» Sequence Show Bus x Values As Line
» Signal Clipboard Draw a line for x bus values instead of a rectangle
» Source Browser

Show Bus z Values As Line
Draw a line for z bus values instead of a rectangle

» Threads E

» Trace X/Val Left Justify Waveform Values

» Transcript Justifies waveform area values to the left

» UVM Configuration v Label Markers By Time

» UVM Factory Markers in the wave window will be shown with time values as

» UVM Testbench labels instead of names

» Variable SO I o L faia et x
» Watch

» Waveform Reset OK Cancel

10.2 Marker Settings, Values, and Preferences

Wave Window 2| Marker = =73 7ts3%t = S
e 20 M2 Marker label 2 02 A LEZ HEOCZ 22|310] HA|L

YIE 4 AOH, 0|5 S| M Marker & F715171

O =
-
&
<
Q
=
~
[¢]
=

EESE Preferences Manager 2| Waveform 7HH| 12| O

HAIE Mootz €8S HEY + USLICL

10.2.1 Changing the Location Marker Labels

Marker Labels £ Waveform x+o| SFEHO| Lt éi':._*oﬂ LIEHE == A& LICE

7| 2™ o 2 Visualizer =

CHO| Marker Labels 2 oF O 2 HEA|GL|CE,

Preferences Manager &
Y2 CSa Z2ELo.

1. Wave &o| O &
QL C}

A+E35L0 Marker Label &

QICHO| A Edit > Preferences... & A EH
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2. (ME AtR) ObF| MEHSIK| §i2 B2 & HO|AM Waveform 7HE| 22| S MEAGIL|CE,
3. 2EZ HO0|AM Display Marker, Event Labels at Top of Window &= H
Marker Labels O] It HA| Yol T 2|2 O|sgL|C,

S0 A(Z 20[=0] Arx| Ao

__11
<
Q
%
o
-
Q
lon
o}
wn
EE
2 rr
=
=
i
Pl
oo R
_?_F
el
el
I
rot
0%

HANSZ LIEE HAl 2
2o ek & AELILE
2} Marker Labels 0| =20 0| LIEILIE S B Z5H= -2 ChSat Z5L T
1. = 0e2 2LEZ HELR 00 HY MFE 1, Display Markers
AEfgtLCt
Markerl (1208200)
Goto
Lock
Delete
Edit LMB+LMB

New Marker @ 1212161
Manage Markers
Display Markers In: Separate Rows
Move Primary Cursor Here Shift+LMB
Move Secondary Cursor Here Shift+RMB
Move Marker To Primary Cursor
Move Marker To Secondary Cursor
&, Show Property Analyzer Curl+5

2. Zf Marker Labels O] Tt HA| ol M 2| tE= T Of2fe| 7HE W22 0| S,
AKX = D|splay Marker, Event Labels at Top of Wlndow 240 wet FepE L

Marker1l 20 22000 1208200

Marker3 11862 1186200]
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10.2.3 Actions on Existing Markers

Wave Window 2| Marker 2} Labels Of
A

- A
- T =
Marker & 27}t S0 = 0|23 EMS =7} A

e 4 s

Marker 2} Marker labels EA

Display Markers M El2 F gL CH

X SH
(=]

Q= of Y

A'Iol

4>
godm

=

—

AN o
|, Ol = HEDH|

(o] IE=
=
o
2

| £ 12{™ Wave Window 2| 00| Af Options & ME45t1

. L . o o
Marker labels 2t EA|SIX| %4 22{H Wave Window 2| O 0| A| Options & MEiSI
. o % .
Display Marker Labels &2 F A8 T}
WaveO - Current
File Edit View (o) Tools Window
v| Auto Reload Wave
V| Pan to Primary Cursor Time
o M v Snap Cursor To Edge
& O Time Units
|
v| Display Global Timeline
Display Horizontal Grid
Display Second Value Column Alt+2
Display Cursor Difference Column
b
& v/ Display Signal Scope Name Ctrl+H
§  Align Base Name ctri+d
Justify Signal Path ’
g v Display Signal File Tag
£ v Display Radix With Value '
= . .
j v Display Leading Zeros (Hex and Oct) 0
£ v Display Secondary Cursor
le -
@ v Display Markers
v| Display Marker Labels
fa N .
v| Display Grid Count Labels
Lock Delta Between Cursors
: Configure Vertical Grid...
=N=3 = = X E=N=1ke1 St = o
Marker & O|S5t2{H 20|28 2IZ0[Lt LEFRC 2 SEOtL B2 oF 2, Efgiatelo]
O]+l O o ES LA
Hot= /XM O A HES SSLICH
= o = A =
D E Marker labels & EIAE O|E0|AM =Xt A|EHO|M A|ZtCZ2 HZASIZH Preferences
= o o
Manager € €11 Waveform 7tH| 2|0 A Label Markers By Time & M EiStL|C}.
£ Preferences Manager ? X|
Find: - # 4 1 V Show Descriptions|
- | e R 2 i =
- Display icons for ports in the name column if true
¥ Flow Navigator Auto Group Create
Launchpad _p
LiveSim Automatically create an empty group at the bottom of the
» Locals signal list if true
» MSNet Show Bus x Values As Line
» Memory Usage Draw a line for x bus values instead of a rectangle
: rl\allessageAwelwe' Show Bus z Values As Line
> Src?qg;nzﬁcna VZEr Draw a .Iine for z bus values instead of a rectangle
» Search Design Left Justify Waveform Values
» Search Files Justifies waveform area values to the left
» Sequence V' Label Markers By Time
» Signal Clipboard Markers in the wave window will be shown with time values as
> g:)“rzce Browser labels instead of names
> Thare:gs Display 'x' as 'X" when more than one bit is '
» Trace X/Val Display :XI"for Hex, ‘.f al\l! bits are x' in binary, le, fvo‘r Octal if all
» Transcript bits are *x" in binary, *X' in decimal if all bits are x' in binary.
» UVM Configuration Add real signals with Wave Display set to Analog Full
» UVM Factory When adding signals of type real to the wave window,
» UVM Testbench automatically set Wave Display to 'Analog FuII
» Variable 2L Ackcd el cicnnle ith YAlais D ttn Analacl =
» Watch
» Waveform . Reset OK | Cancel
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10.2.4 Preferences for Marker Labels

ot

0L 3O riot pXx

—_

.E rr oY o oY

Wave Window 2| M50 A Edit > Preferences...

ol gL ct

=

+>

273 B2|Xe| oty MFoM = Oty ol BAIS= O 2HEe| RS X o=
= MLt
28 #2|X £ 53 Visualizer 2| CHfol EG0f tigh MBS 3t gfE Yolg
CHet &AFYLCE BHE BA = Wave ZOIA OFA 2|0|S0f it &8 288 E=
= 20E 4t

MEHSI™H Preferences Manager

= el oFto o
Z ZolM Waveform 7tE| 12| & A E4SHH(OME] HEHE|X| §E2 HR), OF2fet 20|
s Sto [ = A A
Marker EA|0 E&F2 O|X|= Preferences & & + USLICH
& Preferences Manager ? X
Find: - # 4 1 V Show Descriptions
- together when false =
» Event Order 10 Maximum height of marker rows in multi-row mode
» FSM The number of marker rows that are visible in mult-row mode before
: E:IeSN ) scrolling is enabled
L ag;wn Cha;ggalor Display Marker, Event Labels at Top of Window
LiveSim Display Marker gnd Event Labels at Top of Window if true,
» Locals bottom of the window if false
» MSNet v Display Marker, Event Labels in one row
» Memory Usage Display Marker and Event Labels in one row
: I\;essageAVIelwer v Display Input, Output and InOut Port Icons
ropeny Analyzer Display icons for ports in the name column if true
» Schematic
» Search Design Auto Group Create
» Search Files Automatically create an empty group at the bottom of the signal list if true
» Sequence Show Bus x Values As Line
» Signal Clipboard Draw a line for x bus values instead of a rectangle
¥ Source Browser Show Bus z Values As Line
tartup 5 X
» Threads Draw a line for z bus values instead of a rectangle
» Trace X/Val Left Justify Waveform Values
» Transcript Justifies waveform area values to the left
» UVM Configuration Label Markers By Time
: me _F,:’aclgry h Markers in the wave window will be shown with time values as labels
i VariabIZS‘ ang instead of names
» Watch Display 'x' as 'X' when more than one bit is 'x' .
RO I . | Reset OK Cancel
=l =2 3AZlg A2 O rel S
REZ UM MAYAE SESIAHLE HAE X0 =5 Y0 O|2(%t 7|
MAH2 S
28 HEYLILt
= =l o AL
OK £ 282|510 Preferences Manager &S EH&L|CH
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10.2.5 The wave marker Command

Wave Window GUI 0| A{ @} OtEHZEX| 2, Transcript &0l Wave marker command £
LSt H 0f 2 marker 82 TS = Y2 M, Wave marker command Q1= =3 &|=
A2 orefet Z& LIt

Argument | Action

add Adds a new marker with user-specified name, time, color.

delete Deletes a user-specified marker.

diff Displays the difference in simulation time between each pair of consecutive markers.

goto Moves the primary cursor to user-specified marker.

-help Displays a list of command arguments with a brief description for each.

list Displays a list of current marker names, along with simulation time and color for
each marker.

view

Moves the display to the user-specified marker without moving the primary cursor.
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11 Wave Window - Bookmarks 7|5 A8 4t
Bookmark £ /d5tH 2 Wave &2| x| 20 Het =2 AT E X7t HEE L|LCL

Zt Wave &0|= AtM| S50t3 S50| e, 5013 ‘44 Al 7|2 20| 2(0l: Bookmarko,
Bookmark1, Bookmark2)O| X|MEL|Ct 203 E MET I AFZ2XE X 20|82 48T £+

== = o=

UG Lt
Wave #2| 2t S0t30|= Chg §27F ZELIC
« B0 B2 5= AL F "Bookmark3"dt £2 503 0|§2 X|FeLICH
«  ZIES fle UM Ex=2 ALY & Us A HEAYLCH
o OX = S WM 2O ST AE AZF2 IHY Fof 2 7HEAE|0|L, TR A2
RER IHEAZ YL,
o Qloj= oM Z Fof A 23 E AXYLIT

£d =032 0|35t MYE g +E2= /5451, 2& Yo FE +3 K=
A3 EE U

11.1 Manage Bookmarks Toolbar Button

Manage Bookmark H{ £ Wave & Toolbar 2| Manage Marks B = Ot2foff AUSLICt Manage

Bookmarks... HES 2E6lH CtE1 22 &Y 078 &g = ASLCL
I —*. nel ||o|| o P o ER T Y AR
1000040 « 8 ,
' Qun:k Bookmark T Ctr'I+K'
New Bookmark...
[+ Manage Bookmarks... Ctri+Shift+K
Next Bookmark K
Previous Bookmark Shift+K

Goto Bookmark0 (951335-967663)
Goto Bookmark1 (1000000-1000050)

Table 1 Manage Bookmarks Menu Selections

Menu Selection Action Shortcut

Quick Bookmark Ctrl+K

New Bookmark %Ufﬂ —’F—7f CHat M XHE Sl Af S0t3E S L Ct -
50t3 22| thet 4XHE Eof, M| S0t3E FIt5tALE

Manage Bookmarks N _ R Ctrl+Shift+K
MEio SO0 E HEY, AH|, o|5E &= JASLICH

Next Bookmark MEE 503 50| CHS S0t32 0| ST LILCt K

Previous Bookmark MNEE 503 S£0|A O S0I2Z 0|2 L CH Shift+K

o
List of current bookmarks | SS0|A MEHSIH 7|E O3 2 0|&5THL| L} -
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11.2 Add Bookmark Dialog Box

Add Bookmark &2 At23810] 7|2 0|2 (0f|: Bookmark0, Bookmark1)0| Ot EH 0|22 2

SOPAE 443 & USLCH 8, 0] B B3 20iA9 A% Y B2 ri/H4 AIZS 8FE

ULt

B8 Add Bookmark ? X

Name:
Begin: 951335 || End: 967663 -
OK Cancel

11.3 Manage Bookmarks Dialog Box

Manage Bookmarks && AFE5H M| S0t3E F7H5HAHLE(RI2] Add Bookmark & AHE) 7| &
SO0IAE HY AN £ olag &= ASLCH o Hof| LIEE |O0IAE & # 2 E5HH Wave

= L Hd, o= T M-y
Window O Al s SO 2 HEZ 0|5 = UASLICE
B8 Manage Bookmarks ? *

0 Bookmark0 (951335-96766 | Add
1 Bookmark1 (1000000-1000 -
Edit

Delete

Goto

Close
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12 Wave Window - Waveform Comparison 7|5 A8 4tH
Wave o List oAM= Mot ot Xt0| & 22I5t= o2 S S MSLLICH

12.1 Wave Compare Dialog Box

Wave Compare 7|52 AMESHE &+ 7§2| b HIO[HH|O|A MtYUS Z2{ot HluE - JASLIE
Ol &3l 27 81 =2l AlZ20|d ZutE =I5t Ko|F S 24 = UA2H, Hlu 2tE

oYz MY s AFLIL

oty H|O|H & H|ustr| 9ot HES e = U= Wave Compare dialog box & Of2fet 220,
e ot ol od S Hlud = JASLCHL

*  Wave files(*.db)

. Wave Dataset

*  VCD Files(*.vcd, *.dump)

Reference Wave

File: Tag: F1|~| Manage.Load
1] 500000 1000000
[l [l ] 1 [ [ [ 1 [ 1
1
Begin Time : @ ns End Time : 1321514 ns

Compare Wave

File: Tag: F1 = Manage/Load
1] 500000 1000000

| \ \ 1 \ f \ 1 \ |
[
Begin Time : @ ns End Time : 1321514 ns

Compare Range

1] 00000 1000000

i ' i ] i [ ' 1 ' '
Begin Time : (@ z End Time : [1321514 [2
Select the type of signals to be compared. Time Telerance Display Values Limits

Clocks and Resets

Positive [0 - Maximum Number of Time Points ALL |=
Data Inputs of Flops
Data Outputs of Flops Negative (B = Maximum Mumber of Signals 5808 |-
Save Results in File Browse
Ok Cancel

Hlg wave data & 7| 92t 7|2 THA = CHSaF &L Tt

1. AlE20lds 25t ohd HOHE MIYLILE <wave_file>.db
2. 2AE HET =, OAl A|IZ220[ME dAstn 22 HO|HE MLt

3. Visualizer Ol A Tool > Wave Compare & ME4BFL|LC},

el = LAE XHO|H2 atcomparelog L0 R9fx[0H, O] M2 C|XQl CIHEE|2| 22
ZEO| MY LICE 210 DYl 0] &2 Wave Compare dialog box 2| Save Results in File ZE0f A
(] o
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12.2 Comparing Waveforms From Different Wave Files

CIxtelel CHE AlZ2|ofd 20N of2 7ol /0| oS 2ESD Wave Window Of A
ol s Bote == ASHCEL

rir
o
oE
rlo
J:l
ojo
=

Al 20| ME &3l waveform dataset = 4ot CHS, waveform = H| 1S}
Z& Lo

1. View > Wave & MEHS}I0] Wave Window & & L|LC}

2. Wave Window Of|A| File > List of Wave Files & ME45I0] & 79| Wave It S ZETIL|C}
+ Loaded Wave(s) Files 0| L2 &, HAEZ Wave File & M E{StD Activate &
AL}

« Z} Wave File Of Cist Al MyS X - = JASLC

3. Hlug S MEdghL|CE
o CIXtQI &oj|AM Hlmgh C|Xtel CHY|E O A 23Z 2ot &, Add to Wave & MEHSHH o T
ChR|o| B E MBI Wave Window Of ZE7HEIL|CH
o AN BN st M= E MEHSHY OFRA 2225t 2, Add to Wave & MEHSHL|CE

4. Wave Window Of| A StL} O] 9| A= WS MENGEL|CH
AMS 0|2 F SILHE 0t A 228t Compare > Simple S ME{SHL|C

=M ae| Atoli WZbA SjA| OF2 2 BAIEL|CH _
+ Show/Hide Differences HE2 S2I3}0] ¢jA| 012 HA|S BAs/H EAsS = |
ALt

6. A

EH
EE = Next

4
m

HSE Al

—_ =

tot

IEL AN 29| L XO|AH S 2 0|5 382{™ Previous Difference gq.
L

pE

Wave Window O|Af MEHEl = A ZtO] H|w X}O|&= CHS 1t ZH0| EA|E L|CL.
. F1.top.dutA1.fast_CLK_count[5]
. F1.top.dutA1.fast_CLK_count[0]

9
=
D
@
o)
(@)
D
T
rim
o
mulu
Ju
ot
=]

- Curren
File Edit View Options Tools Window

CBO0| QREEEA MM | 12T Ff| | al1e0 Halo =] Diff 186[lns -] Freq 16.808MHz -| |¥ R T LIS
signal Name values C1 5080

(_count[14]

.top.dutal L count[13]
.Lop.dutal LK_count[12]
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12.3 Comparing Time-Shifted Waveforms
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12.4 Finding the First Signal Difference With the List Window
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