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1 QuestaSim Visualizer Debug Environment 소개  

 

QuestaSim 2023.1버전부터 Visualizer Debug Environment 제품이 포함되었습니다.  

QuestaSim Visualizer Debug Environment 는 QuestaSim 에서 얻은 데이터를 Visualizer GUI 로 열고,  

Visualizer 의 다양한 Advanced 디버깅 기능을 통해 디자인을 쉽게 분석하고 디버깅할 수 있는 Tool 입니다. 
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QuestaSim Visualizer는 기존의 QuestaSim Classic에 비해 시뮬레이션 성능이 2배 빠르며, 웨이브폼 데이터를 

저장할 때에도 3배 이상 적은 용량으로 저장됩니다. 이러한 특징 덕분에 디스크 공간을 절약하면서도 빠른 

시뮬레이션 결과를 얻을 수 있습니다. 

 

 

 

2 QuestaSim Visualizer Debug Environment 실행 방법 

 

QuestaSim Visualizer 는 2가지 모드로 호출할 수 있습니다. 

2가지 모드는 QuestaSim 의 3-Step Flow(Compilation, Optimization, Simulation) 를 사용합니다. 

이 때, Optimization 단계와 Simulation 단계에서는 QuestaSim Visualizer 호출과 관련된 파일을 생성하는 

옵션이 포함되어 있습니다. 

 

2.1 Post-Simulation 모드 

 

post-sim 모드는 시뮬레이션 완료된 Design Information 파일과 Simulation(waveform) Database 파일을  

QuestaSim Visualizer GUI 로 열어서 디자인을 분석하고 디버깅할 수 있습니다.  

단, 시뮬레이션 진행이 완료되었기에 breakpoints, restart, run 명령을 사용할 수 없습니다. 

 

1-Step    (Compilation: Compile Verilog/VHDL rtl files with vlog/vcom command) 

vlog <verilog_rtl>.v 

vcom <vhdl_rtl>.vhd 

 

2-Step    (Optimization: Optimize design with vopt command for debuggability) 

vopt <design_top_name> -o <optimized_name> -debug -designfile design.bin  

 

3-Step    (Simulation: Run Simulation with options for qwave dump) 

vsim -c <optimized_name> -do “run -all; quit -f” -qwavedb=+signal+memory+wavefile=qwave.db  

 

4-Step    (Invoking Visualizer) 

vis design.bin qwave.db 

 

 

옵션 설명은 “QuestaSim Visualizer 의 Post-sim / live-sim 옵션” 항목을 참고해 주시기 바랍니다. 
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2.2 Live-Simulation 모드 

 

live-sim모드는 기존 QuestaSim Classic 의 실행 방식과 비슷하다고 볼 수 있습니다.  

즉, QuestaSim Visualizer GUI 로 열고나서 breakpoints, restart, run 등의 명령을 실행할 수 있습니다.  

 

1-Step    (Compilation: Compile Verilog/VHDL rtl files with vlog/vcom command) 

vlog <verilog_rtl>.v 

vcom <vhdl_rtl>.vhd 

 

2-Step    (Optimization: Optimize design with vopt command for debuggability) 

vopt <design_top_name> -o <optimized_name> -debug,livesim -designfile design.bin  

 

3-Step    (Simulation: Run Simulation with options for qwave dump) 

vsim -visualizer=design.bin <optimized_name> -qwavedb=+signal+memory+wavefile=qwave.db  

 

 

 

옵션 설명은 “QuestaSim Visualizer 의 Post-sim / live-sim 옵션” 항목을 참고해 주시기 바랍니다. 
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3 QuestaSim Visualizer 의 Post-Sim / Live-Sim 옵션 

 

vopt options 

-o <optimized name> 

: Design Top 에 대한 <optimized name>이라는 이름의 최적화된 디자인을 생성합니다.  

 

-debug 

: Post-sim 모드에서 디버깅을 위해 사용합니다. 

 

-debug, livesim 

: live-sim 모드에서 디버깅을 위한 breakpoint, restart 등의 기능을 활성화하기 위해 사용됩니다. 

 

-designfile design.bin 

: Visualizer Tool에서 사용할 디자인 정보 파일(design.bin)을 생성합니다.  

이 파일은 디버깅 시 필요한 정보를 포함하고 있습니다. 

 

vsim options 

-c  

: command-line 모드에서 시뮬레이터를 실행하도록 지정합니다.  

 

-do  

: “<command_string>” 에 지정된 명령을 수행하거나 혹은 DO 파일을 실행하도록 지시합니다. 

 

-visualizer=design.bin 

: live-sim 모드에서 Visualizer 를 실행할 때 사용합니다. 

이 때, 디자인 정보 파일(design.bin)을 포함시켜 Visualizer 를 호출합니다. 

 

-qwavedb 

: Simulation(Waveform) DB 파일을 생성합니다.  

이 옵션은 다음과 같은 추가 옵션을 포함할 수 있습니다: 

 

+signal   : Simulation DB에 Signal 을 기록합니다. 

+memory  : 메모리 관련 항목을 기록합니다. 

+wavefile=qwave.db : Simulation 결과를 qwave.db 파일에 저장합니다. 

 

vis(=visualizer) 

: vis 혹은 visualizer 명령을 입력하여 Visualizer Debug Environment 를 호출합니다. 

이 때, Optimization과 Simulation 단계에서 생성된 design.bin, qwave.db 파일을 지정하여 호출할 수 있습니다. 

  



 

6 

 

4 Waveform Database(qwave.db) 파일만으로 QuestaSim Visualizer 실행하는 방법 

 

QuestaSim Visualizer 는 디자인 파일이나 작업 라이브러리와 관계없이 Waveform 데이터만 볼 수 

있는 wave view 모드를 제공합니다. 이 모드를 사용하면 IP나 큰 디자인 파일을 포함하지 않고도 

시뮬레이션 결과를 쉽게 공유할 수 있습니다. 

 

실행 절차는 다음과 같습니다: 

1. Waveform Database 파일(qwave.db) 생성: 

 2.1절 Post-Simulation 모드의 지침에 따라 qwave.db 파일을 생성합니다. 

 

2. QuestaSim Visualizer 에서 wave view 모드 실행: 

 CLI:  visualizer -wavefile wavefile   (예: visualizer -wavefile qwave.db) 

 

 GUI:  QuestaSim Visualizer 상단 메뉴의 File > Load Design… 을 클릭합니다.  

창이 나타나면, Load Wave File 항목에 파형 파일을 선택하고 Load 버튼을 클릭합니다. 

 

 

 

wave view 모드를 실행하면, 다음과 같은 window만 표시됩니다: 

 Design window 

 Variables window  

 Wave window 
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5 Visualizer 검색 기능 사용 방법 

 

Visualizer 는 현재 로드된 디자인 내부에서 단어나 문장을 찾는 여러 방법을 제공합니다. 

 

5.1 각각의 Window 내에서 검색 기능 사용 방법 

 

Visualizer 에 있는 대부분의 Window 에서는 검색할 수 있는 기능을 제공합니다.  

검색 기능을 사용하는 방법은 다음과 같습니다: 

 메인 메뉴에서 Edit>find 를 선택합니다. 

 키보드에서 Ctrl+F 를 누릅니다. 

 

 

 

검색하고 싶은 단어를 입력한 다음 Enter를 누르거나 Find Next 버튼을 클릭합니다. 

일반적으로 사용되는 Window 는 다음과 같습니다. 

 Source Window / Transcript Window / Message Viewer Window 

 

일부 Window 는 아래와 같은 추가 검색 기능을 제공합니다. 

 

Find Strip 기능 

 

Find Strip은 텍스트가 순서대로 나열되거나 트리 계층 구조로만 표시되는 Window 에서 사용됩니다. 

이 기능은 Window 하단에 나타나며, 검색하려는 단어를 입력하는 부분과 이전에 검색했던 단어를 

볼 수 있는 드롭다운 목록이 있습니다. 

 

 

 

검색하고 싶은 단어를 입력한 다음 Enter 를 누릅니다. 

일반적으로 사용되는 Window 는 다음과 같습니다. 

 Locals Window / Files Window / Variables Window 

 Classes Window / Class Instances Window / Sequence Window 
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filter Strip 기능 

 

filter Strip 은 Window 안의 단어를 필터링(원하는 내용만 보기)하기 위해 사용됩니다.  

필터링하려는 단어를 입력하는 부분과 이전에 필터링했던 단어들을 볼 수 있는 목록이 있습니다. 

 

 

 

Design, Schematic, Wave Windows 는 다른 방식으로 검색 기능을 제공합니다. 

 

5.2 Search Design Window 에서 검색 기능 사용 방법 

 

메뉴에서 View>Search Design 을 선택하거나 Ctrl+Shift+A 단축키로 Search Design Window 를 

열 수 있습니다. 

 

Search Design Window 에서는 Module 또는 Scope 를 선택하여 현재 디자인 내에서 찾고 싶은 

단어를 검색할 수 있습니다. Filter 필드에 단어를 입력하면, 해당 단어와 일치하는 결과만을 표시할 

수 있습니다. 
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우측 상단에 있는 Object Types… 버튼을 클릭하면, 더 자세히 찾고 싶은 유형을 선택하여 결과를 

필터링할 수 있습니다. 

 

 

 

5.3 Search Files Window 에서 검색 기능 사용 방법 

 

메뉴에서 View>Search Files 을 선택하거나 Ctrl+Shift+F 단축키로 Search Files Window 를 열 수 

있습니다. 

 

Search Files Window 를 통해, 모든 파일에서 원하는 텍스트를 검색할 수 있습니다.  

결과는 각각의 행에 표시되며, 파일 위치, 줄 번호 같은 추가 정보도 함께 보여줍니다.  

Search Files Window 에서는 파일 내용 중 원하는 텍스트를 찾아 다른 텍스트로 교체할 수 있습니다. 
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6 화면 및 텍스트 크기 조절 방법 

 

QuestaSim Visualizer 에서 화면 및 텍스트 크기를 조절하는 방법은 다음과 같습니다: 

 

1. Edit 메뉴에서 Preference (Ctrl-N) 를 선택합니다.  

General > Font 를 선택한 후, Font / Font Style / Size 를 설정할 수 있습니다. 

 

 

 

2. 전체 화면 및 텍스트의 크기를 조절하고자 하는 경우, Ctrl 키와 + 또는 - 키를 누르면 

됩니다. 이를 통해 전체 화면의 크기를 쉽게 조절할 수 있습니다. 

 

3. 특정 창에서만 화면 및 텍스트의 크기를 조절하고자 하는 경우, Ctrl 키와 0 또는 9 키를 

누르면 됩니다. 이를 통해 현재 활성화된 창의 크기만을 조절할 수 있습니다. 

 

이렇게 QuestaSim Visualizer 는 사용자의 편의를 위해 화면 및 텍스트 크기 조절 기능을 제공하고 

있습니다. 이 기능을 활용하면 작업을 보다 편리하게 진행할 수 있습니다. 
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7 Wave Window – Radix 할당 방법 

 

Wave Window 에서는 특정 신호에 Radix를 할당할 수 있습니다. 

 

1. Wave Window의 Signal Name열에서 다음 방법으로 Radix를 할당할 신호를 선택합니다.  

 인접하지 않은 여러 신호 선택 

: 나란히 나열되지 않은 신호의 경우, 마우스를 신호 이름 위로 이동한 후 Ctrl 키를 누른 

상태에서 클릭합니다. 각 신호에 대해 이 과정을 반복합니다. 

 연속적으로 인접한 여러 신호 선택 

: 나란히 나열되어 있는 신호의 경우, 첫 번째 신호를 클릭한 후 Shift 키를 누른 

상태에서 마지막 신호를 클릭하여 선택합니다.  

 모든 신호 선택 

: 신호 이름을 클릭한 후 Ctrl+A키를 누르거나, Edit > Select All을 선택합니다. 

 

2. 선택한 신호에 대해 마우스 오른쪽 버튼을 클릭한 후, 원하는 Radix 유형을 선택하여 

할당합니다. Radix 유형별로 단축키가 설정되어 있어 빠르게 Radix를 할당할 수 있습니다. 

 

 

또한, Edit>Preferences를 통해 환경설정 관리자에서 Default Radix 를 변경할 수 있으며, 할당된 

Radix가 Values 열에 표시되도록 설정하거나 해제할 수 있습니다. 

 

 

이 방법으로 특정 신호의 Radix를 쉽게 할당할 수 있습니다. 
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8 Wave Window – 신호 저장 및 로드 방법 

 

Wave Window에서는 모든 신호나 선택한 신호에 대해 목록을 저장하고, 저장된 목록 파일을 다시 

불러올 수 있습니다. Visualizer 는 기본적으로 다음과 같은 특성을 포함하여 .do 파일로 신호를 

저장합니다. 

 

: Zoom Level, Pan Position, Pane and Grid Markers, Nested Groups, Background Color,  

Foreground Color, Signal Height, Radix Settings, Markers, Grids, Groups 

 

Signal List 파일을 저장하는 방법은 아래와 같습니다. 

 

1. Wave Window에 신호를 추가합니다. 

2. Wave Window에 있는 모든 신호를 저장하지 않으려면 저장할 신호를 선택합니다. 

3. 선택한 신호 저장) 선택한 신호를 저장하려면 File > Save Selected Signal List 를 선택합니다. 

4. 모든 신호 저장) 모든 신호를 저장하려면 File > Save Signal List(Ctrl+S) 를 선택합니다. 

5. Save Signal List File 대화 상자가 열리면, .do 확장자로 파일을 저장합니다. 

 

저장된 Signal List 파일을 로드하는 방법은 아래와 같습니다. 

 

1. 빈 Wave Window를 엽니다. 

2. File > Load Signal List 를 선택하여 Read Signal List File 대화 상자를 엽니다. 

3. 원하는 .do 파일을 선택합니다. 

 

시작 시 Signal List 파일을 로드하는 방법은 아래와 같습니다. 

 

1. 터미널 창에서 다음 명령을 입력합니다. 

visualizer -designfile <design_filename> -wavefile <wave_filename> -do <signal_filename>.do 

 

 

이 방법으로 Signal List 파일을 쉽게 저장하고 불러올 수 있습니다. 
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9 Wave Window – Search 기능 사용 방법 

 

Wave Window 에서는 signal 이름, 특정 wave signal 의 transition 그리고 지정된 transition의 모든 

인스턴스를 검색할 수 있습니다. 

 

9.1 Finding Signals by Name 

 

Source Window 에서 이미 로드된 신호를 검색할 수 있습니다. 

검색 방법은 다음과 같습니다. 

 

1. Source Window 에서 검색하려는 신호 이름을 마우스 오른쪽 버튼으로 클릭하고 Highlight 

In Wave를 선택합니다. 

 

 

2. 선택한 신호는 Wave Window 에 하이라이트 표시됩니다. 

 

 

9.2 Searching for Transitions 

 

Wave Window 에서는 개별 신호의 transition 을 검색할 수 있으며, Single transition 또는 Multiple 

transition 중 선택하여 진행할 수 있습니다. 

 

Single transition 을 검색하는 방법은 다음과 같습니다. 
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1. Waveform 창에서 signal transition 을 클릭하여 검색 시작하려는 시뮬레이션 시간에  

기본 커서를 놓은 다음, 신호 이름을 마우스 오른쪽 버튼으로 클릭하고 Search Selected 

Signal…(Ctrl+Shift+F) 을 선택합니다. 

 

 

2. Search Selected Signal 창에서 Value transition from: 및 To: 필드에 값을 입력합니다. 

 

 

3. Previous 또는 Next 를 클릭하여 transition 을 찾습니다. 

 

 

Multiple transitions 을 검색하는 방법은 다음과 같습니다. 

 

1. Waveform 창에서 신호 이름을 마우스 오른쪽 버튼으로 클릭하고 Grid Events…를 

선택합니다. 

 

 

2. Grid Events 창이 열리면 다음을 설정합니다. 

 Grid Source 선택 

 Value Transition 지정 

 Time Settings 선택 
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3. Add Grid 버튼을 클릭합니다. (Grid Events는 현재 생성된 Wave 창에서만 고유합니다.) 

 

 

특정 transition을 검색하면 기본 커서가 새 transition 으로 이동되며, 새 transition이 현재 

디스플레이 밖에 있으면 Wave 창이 자동으로 스크롤되어 해당 transition이 중앙에 표시됩니다. 

 

Grid Events 창으로 검색하는 경우, Wave window에서는 transition 위치가 회색 마커로 표시됩니다. 
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9.3 Biometric Search for Multiple Signal Values 

 

Wave Window 에서는 모든 신호에서 지정된 값의 모든 인스턴스를 검색하고 표시할 수 있습니다. 

 

사용자가 입력한 값을 기반으로 신호를 빠르게 찾아 표시하고 새로 추가된 신호도 자동으로 검색해 

표시하여 시뮬레이션 중 특정 값을 신속하게 추적하고 관리할 수 있습니다. 

 

Biometric Search 설정하는 방법은 아래와 같습니다. 

 

1. 검색하려는 값을 포함하는 signal transition 을 클릭하여 주 커서를 해당 위치에 놓고, 

Wave Window 에서 Tools > Biometric Search.. (Alt+B) 를 선택하여 Biometric Search 창을 

띄웁니다. 

 

 

 

 

2. Add 버튼을 클릭하여 Wave Search 창을 열면, 선택한 signal transition 값이 Search Value 

필드에 자동으로 입력되며, 필요에 따라 다른 값을 입력할 수도 있습니다. 

 

 

3. Color 박스를 클릭하여 검색된 값을 표시할 색상을 선택합니다. 
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4. Ok 버튼을 클릭하여 설정을 완료하면, Biometric Search 창에 지정한 검색 값이 표시됩니다. 

 

 

5. Next 또는 Prev 버튼을 클릭하여 선택한 값의 다음 또는 이전 인스턴스를 찾게 되는데, 

이때 기본 커서가 해당 값의 다음 또는 이전 인스턴스로 이동하고, 신호 이름이 강조 

표시되며, 시뮬레이션 시간이 GUI 전체에서 업데이트됩니다. 

 

 

6. 원하는 값을 모두 찾으면 Biometric Search 창을 닫습니다. 

 

이 기능을 통해, 지정한 값의 모든 인스턴스가 선택한 색상으로 표시되며, Waveform 창을 축소하면 

지정된 값의 인스턴스들이 작은 점으로 표시되고, 이렇게 표시된 점들을 통해 Waveform 에서 지정된 

값이 발생한 위치를 쉽게 식별할 수 있습니다. 
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10 Wave Window – Marker 기능 사용 방법 

 

Wave Window 에서는 Marker 를 생성해 X축(시뮬레이션 시간)의 특정 위치를 저장하고 레이블을 

지정할 수 있습니다. Marker 는 수직 식별자로, 스크롤해도 고정된 위치에 남아 있어 저장한 위치로 

쉽게 돌아갈 수 있으며, 모든 Marker 는 생성된 Wave Window 에만 적용되며 다른 창으로 공유되지 

않습니다. 

 

10.1 Adding A Wave Window Marker 

 

Wave Window 에서 Manage Markers 버튼을 사용하여 팝업 메뉴를 표시하는 방법은 아래와 같으며, 

이 메뉴에서 waveform marker 를 배치하고 편집할 수 있습니다. 

 

1. Signal waveform 에서 원하는 transition의 가장자리를 찾으려면 파형 표시를 수평으로 

스크롤합니다. 

2. 해당 transition을 클릭하면 해당 시뮬레이션 시간의 기본 커서(C1)가 X축에 배치됩니다. 

3. 파형에 marker를 추가하는 방법은 다음과 같습니다. 

 C1 의 현재 위치에 Quick Marker(기본 설정 사용) 추가는 아래의 방법 중 하나로  

진행하면 됩니다. 

- Ctrl+M 을 누릅니다. 

- Manage Markers 버튼을 클릭하고 Quick Marker 를 선택합니다. 

 

 삽입 전에 설정을 사용자 정의할 수 있는 New Marker를 추가하는 방법은 다음과 

같습니다. 

1. Manage Markers 버튼을 클릭하고 New Marker 를 선택하면, Add Marker 

창이 띄워집니다. 
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2. Name 필드에 Marker 이름으로 지정하려는 문자를 입력합니다(공백과 특수 

문자 혀용, 예: Marker + 1). 시간 및 단위의 기본값은 기본 커서(C1)의 현재 

위치입니다. 

3. (선택 사항) 기본값에서 시간, 단위 또는 색상에 대한 설정을 변경합니다. 

4. Ok 버튼을 클릭하면, 아래와 같이 해당 위치에 Marker 가 배치됩니다. 

 

 

4. (선택 사항) 기존 Marker 의 설정을 변경합니다. 

1. Marker label (예: Marker1) 을 두 번 클릭하면, 다음 항목에 대해 다양한 값을 

지정할 수 있는 Edit Marker 창이 열립니다. 

 

 Name (기본값은 Marker1) 

 Time (기본적으로 이 값은 기본 커서의 위치입니다.) 

 Color (Select Color 창이 열리고 팔레트에서 색상을 선택하거나 RGB 또는 

16진수 값을 지정하여 Marker 색상을 지정할 수 있습니다.) 

 

2. Ok를 클릭하면 Edit Marker 창이 닫히고 변경 사항이 적용됩니다. 

 

5. 파형에서 다른 시뮬레이션 시간을 클릭하면 커서 위치가 좌우로 이동하며, 커서를 

이동해도 Marker와 label은 지정된 위치에 그대로 유지됩니다. 

 

Marker 를 추가하면 Waveform 창의 지정된 시뮬레이션 시간에 수직선이 표시되며, 해당 레이블은 

창 하단에 나타나고 기본적으로 여러 Marker 의 레이블은 창 하단에 단일 행으로 표시됩니다. 
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다음 설정으로 Preferences Manager 에서 기본 설정을 변경할 수 있습니다. 

 Display Marker, Event Labels at Top of Window  

– 이 옵션을 선택하면 Marker labels 가 파형 표시 영역의 상단으로 이동합니다. 

 Display Marker, Event Labels in one row (기본적으로 선택됨)  

– 각 Marker label을 별도의 행에 표시하려면 이 옵션을 선택 취소합니다. 

 

 

10.2 Marker Settings, Values, and Preferences 

 

Wave Window 의 Marker 는 수정 가능한 여러 기본값과 환경 설정을 제공합니다. 

대부분의 설정은 Marker label을 마우스 오른쪽 버튼으로 클릭하여 표시되는 팝업 메뉴를 통해 

접근할 수 있으며, 이를 통해 새 Marker를 추가하거나 기존 Marker를 수정할 수 있습니다. 

또한 Preferences Manager 의 Waveform 카테고리 아래에서 Wave Window 에서 Marker labels 의 

표시를 제어하는 설정을 변경할 수 있습니다. 

 

10.2.1 Changing the Location Marker Labels 

 

Marker Labels 은 Waveform 창의 하단이나 상단에 나타날 수 있습니다. 

기본적으로 Visualizer 는 파형 표시 영역의 하단에 Marker Labels 을 한 행으로 표시합니다. 

 

 

Preferences Manager 를 사용하여 Marker Label 을 파형 표시 영역의 맨 위로 이동하는 

방법은 다음과 같습니다. 

 

1. Wave 창의 메뉴 막대에서 Edit > Preferences… 를 선택하면 Preferences Manager 창이 

열립니다. 
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2. (선택 사항) 아직 선택하지 않은 경우 왼쪽 창에서 Waveform 카테고리를 선택합니다. 

3. 오른쪽 창에서 Display Marker, Event Labels at Top of Window 항목의 체크박스를 

선택하면, Marker Labels 이 파형 표시 영역의 맨 위로 이동합니다. 

4. OK 를 클릭합니다. 

 

 

10.2.2 Changing the Row Display of Marker Labels 

 

Marker Labels 은 파형 표시 영역 내에서 단일 행 또는 별도의 행(각 레이블이 자체 행에 

표시)으로 나타날 수 있습니다. Marker Labels 의 팝업 메뉴를 사용하여 이러한 행 표시 방법 

간에 전환할 수 있습니다. 

 

각 Marker Labels이 별도의 행에 나타나도록 변경하는 방법은 다음과 같습니다. 

 

1. Marker Label 을 마우스 오른쪽 버튼으로 클릭하여 팝업 메뉴를 열고, Display Markers 

In: Separate Rows를 선택합니다. 

 

 

2. 각 Marker Labels이 파형 표시 영역의 맨 위 또는 맨 아래의 개별 행으로 이동하며, 

위치는 Display Marker, Event Labels at Top of Window 설정에 따라 달라집니다. 
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10.2.3 Actions on Existing Markers 

 

Wave Window의 Marker와 Labels에는 수정할 수 있는 여러 특성이 있습니다. 하나 이상의 

Marker를 추가한 후에는 이러한 특성을 추가, 삭제, 이동 또는 편집하기 위한 다양한 작업을 

수행할 수 있습니다. 

 

 Marker와 Marker labels 표시를 끄려면 Wave Window의 메뉴에서 Options 을 선택하고 

Display Markers선택을 취소합니다. 

 Marker labels만 표시하지 않으려면 Wave Window의 메뉴에서 Options을 선택하고 

Display Marker Labels 선택을 취소합니다. 

 

 

 Marker를 이동하려면 레이블을 왼쪽이나 오른쪽으로 클릭하고 드래그 한 후, 타임라인의 

원하는 위치에서 마우스 버튼을 놓습니다. 

 모든 Marker labels을 텍스트 이름에서 숫자 시뮬레이션 시간으로 변경하려면 Preferences 

Manager를 열고 Waveform카테고리에서 Label Markers By Time 을 선택합니다. 
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10.2.4 The wave marker Command 

 

Wave Window GUI에서와 마찬가지로, Transcript 창에 Wave marker command 를 

입력하면 여러 marker동작을 수행할 수 있으며, Wave marker command 인수와 수행되는 

작업은 아래와 같습니다. 

 

Argument Action 

add Adds a new marker with user-specified name, time, color. 

delete Deletes a user-specified marker. 

diff Displays the difference in simulation time between each pair of consecutive markers. 

goto Moves the primary cursor to user-specified marker. 

-help Displays a list of command arguments with a brief description for each. 

list Displays a list of current marker names, along with simulation time and color for 

each marker. 

view Moves the display to the user-specified marker without moving the primary cursor. 
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11 Wave Window – Bookmarks 기능 사용 방법 

 

Bookmark를 생성하면 활성 Wave 창의 현재 확대 범위와 수직 스크롤 위치가 저장됩니다. 

각 Wave 창에는 자체 북마크 목록이 있으며, 북마크 생성 시 기본 레이블(예: Bookmark0, 

Bookmark1, Bookmark2)이 지정됩니다. 북마크를 생성할 때 사용자 지정 레이블을 설정할 수도 

있습니다. 

 

Wave 창의 각 북마크에는 다음 정보가 포함됩니다. 

 

 나중에 참조할 수 있도록 "Bookmark3"과 같은 북마크 이름을 지정합니다. 

 리콜을 위한 대체 참조로 사용할 수 있는 숫자 식별자입니다. 

 현재 확대 수준. 현재 확대 수준의 시작 시간은 파형 창의 왼쪽 가장자리이고, 종료 시간은 

오른쪽 가장자리입니다. 

 웨이브 창에서 각 창의 현재 스크롤 위치입니다. 

 

특정 북마크로 이동하면 저장된 배율 수준으로 확대/축소되고, 모든 창이 저장된 수직 위치로 

스크롤됩니다. 

 

11.1 Manage Bookmarks Toolbar Button 

 

Manage Bookmark버튼은 Wave 창 Toolbar의 Manage Marks 버튼 아래에 있습니다. Manage 

Bookmarks… 버튼을 클릭하면 다음과 같은 작업 메뉴를 확인할 수 있습니다. 

 

 

Table 1 Manage Bookmarks Menu Selections 

Menu Selection Action Shortcut 

Quick Bookmark 
Wave 창의 파형 창의 현재 확대 레벨과 스크롤 위치를 

사용하여 책갈피를 만듭니다. 
Ctrl+K 

New Bookmark 북마크 추가 대화 상자를 통해 새 북마크를 만듭니다. - 

Manage Bookmarks 
북마크 관리 대화 상자를 열어, 새 북마크를 추가하거나 

선택한 북마크를 편집, 삭제, 이동할 수 있습니다. 
Ctrl+Shift+K 

Next Bookmark 저장된 북마크 목록에서 다음 북마크로 이동합니다. K 

Previous Bookmark 저장된 북마크 목록에서 이전 북마크로 이동합니다 Shift+K 

List of current bookmarks 목록에서 선택하면 기존 북마크로 이동합니다. - 
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11.2 Add Bookmark Dialog Box 

 

Add Bookmark 창을 사용하여 기본 이름(예: Bookmark0, Bookmark1)이 아닌 특정 이름으로 

북마크를 생성할 수 있습니다. 또한, 이 창을 통해 북마크의 시작 및 종료 확대/축소 시간을 설정할 수 

있습니다. 

 

 

11.3 Manage Bookmarks Dialog Box 

 

Manage Bookmarks 창을 사용하여 새 북마크를 추가하거나(위의 Add Bookmark 창 사용) 기존 

북마크를 편집, 삭제 또는 이동할 수 있습니다. 이 창에 나열된 북마크를 두 번 클릭하면 Wave 

Window 에서 해당 북마크로 바로 이동할 수 있습니다. 
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12 Wave Window – Waveform Comparison 기능 사용 방법 

 

Wave 및 List 창에서는 신호와 파형 차이를 확인하는 여러 방법을 제공합니다. 

 

12.1 Wave Compare Dialog Box 

 

Wave Compare 기능을 사용하면 두 개의 파형 데이터베이스 파일을 불러와 비교할 수 있습니다. 

이를 통해 설계 변경 전후의 시뮬레이션 결과를 확인하고 차이점을 분석할 수 있으며, 비교 결과를 

파일로 저장할 수도 있습니다. 

 

파형 데이터를 비교하기 위한 설정을 입력할 수 있는 Wave Compare dialog box 는 아래와 같으며, 

다음 파일 유형의 파형을 비교할 수 있습니다. 

 Wave files(*.db)  

 Wave Dataset 

 VCD Files(*.vcd, *.dump) 

 

 

 

비교할 wave data를 얻기 위한 기본 단계는 다음과 같습니다. 

 

1. 시뮬레이션을 실행하고 파형 데이터를 저장합니다. <wave_file>.db  

2. 설계를 변경한 후, 다시 시뮬레이션을 실행하고 새로운 데이터를 저장합니다. 

3. Visualizer 에서 Tool > Wave Compare 를 선택합니다. 

 

진행 후 발견된 차이점은 atcompare.log 파일에 요약되며, 이 파일은 디자인 디렉토리의 최상위 

경로에 저장됩니다. 결과 파일의 이름은 Wave Compare dialog box 의 Save Results in File 필드에서 

확인할 수 있습니다. 
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12.2 Comparing Waveforms From Different Wave Files 

 

동일한 디자인의 다른 시뮬레이션 실행에서 여러 개의 웨이브 파일을 로드하고 Wave Window에서 

차이점을 평가할 수 있습니다.  

 

시뮬레이션을 통해 waveform dataset 을 생성한 다음, waveform 을 비교하는 방법은 다음과 

같습니다. 

 

1. View > Wave 를 선택하여 Wave Window를 엽니다. 

2. Wave Window 에서 File > List of Wave Files 를 선택하여 두 개의 Wave 파일을 로드합니다. 

• Loaded Wave(s) Files 창이 나오면, 테스트할 Wave File을 선택하고 Activate 를 

설정합니다. 

• 각 Wave File 에 대한 식별 색상을 지정할 수 있습니다. 

3. 비교할 대상을 선택합니다. 

• 디자인 창에서 비교할 디자인 단위를 마우스 우클릭한 후, Add to Wave 를 선택하면 해당 

단위의 모든 신호가 Wave Window 에 추가됩니다. 

• 소스 창에서 원하는 신호를 선택하여 마우스 우클릭한 후, Add to Wave 를 선택합니다. 

4. Wave Window 에서 하나 이상의 신호 쌍을 선택합니다. 

5. 신호 이름 중 하나를 마우스 우클릭하고, Compare > Simple 을 선택합니다. 

• 두 신호 간의 차이는 빨간색 해시 마크로 표시됩니다.  

• Show/Hide Differences 버튼을 클릭하여 해시 마크 표시를 활성화/비활성화할 수 

있습니다. 

6. 선택한 신호 또는 신호 그룹의 다음 차이점으로 이동하려면 Previous Difference 

또는 Next Difference 버튼을 클릭합니다. 

 

Wave Window 에서 선택된 두 신호 간의 비교 차이는 다음과 같이 표시됩니다. 

 F1.top.dutA1.fast_CLK_count[5] 

 F1.top.dutA1.fast_CLK_count[0] 
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12.3 Comparing Time-Shifted Waveforms 

 

Wave Window 에서는 선택한 파형을 특정 시간만큼 이동하여 원본과 비교할 수 있습니다. 

이를 통해 시간 차이에 따른 신호 변화를 시각적으로 분석할 수 있습니다. 

 

진행 방법은 다음과 같습니다. 

 

1. Wave Window 의 신호 이름 열에서 하나 이상의 파형을 선택합니다. 

2. 마우스 우클릭해서 Wave Window 팝업 메뉴를 열고, Expression > Shift Wave 를 

선택합니다. 

3. Shift Wave 창이 나오면 다음 방법 중 하나를 선택하여 이동할 시간을 설정합니다. 

• Cursor Delta Value : 기본 커서와 보조 커서의 시간 차이를 자동으로 계산하여 이동 

• Custom Value : 원하는 숫자 값을 직접 입력하여 이동 

 

 

4. OK를 클릭하면 선택한 파형의 복사본이 지정한 시간만큼 이동하여 표시됩니다. 

5. (선택 사항) Signal Name 열에서 마우스 우클릭한 후, Compare > Simple 을 선택하면 

이동된 파형과 원본 파형이 비교되며, 차이점은 색상으로 강조 표시됩니다. 

 

 120ns 만큼 이동된 파형 쌍의 예시는 아래와 같습니다. 

 

 

 100ns 만큼 이동된 실수 값 파형의 예시는 아래와 같습니다. 
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12.4 Finding the First Signal Difference With the List Window 

 

시뮬레이션 실행 중 발생한 오류는 여러 신호에 전파될 수 있으므로 신호 쌍에서 첫 번째 차이점을  

찾는 것은 디버깅 시 도움이 될 수 있습니다. 이를 위해 List Window를 활용하여 특정 영역 또는 

신호 그룹에서 첫 번째 차이점을 찾을 수 있습니다. 

 

시뮬레이션을 실행하여 참조 파형 파일과 테스트 파형 파일을 생성한 후 비교를 진행합니다. 

진행 방법은 다음과 같습니다. 

 

1. Wave Window 에서 File > List of Wave Files 을 선택하여 두 개의 Wave 파일을 로드합니다. 

• Loaded Wave File 창이 나오면 비교할 테스트 Wave 파일과 참조 Wave 파일을 로드하고  

활성화할 Wave 파일을 설정하고 각 파일의 식별 색상을 지정합니다. 

2. 비교 대상을 선택합니다. 

• Design Window 에서 design unit을 마우스 우클릭하고 Add to List 를 선택하면 해당 

design unit의 모든 신호가 List Window 에 추가됩니다. 

• Source Window 에서 특정 신호를 마우스 우클릭하고 Add to List를 선택하면 개별 

신호가 List Window 에 추가됩니다. 

3. List Window에서 신호 중 하나를 마우스 우클릭하고 Sort and Uniquify 를 선택합니다.  

• 중복된 신호가 제거되고 신호가 전체 경로 이름 순으로 정렬되며 필요에 따라 Search 

Depth를 설정하여 검색 범위를 조정할 수 있습니다. 

4. List Window에서 비교할 신호를 선택하고 Wave Compare 버튼을 클릭합니다. 

5. Wave Compare 창이 나오면 비교할 시뮬레이션 구간의 시작과 종료 시간을 입력합니다. 

6. OK를 클릭합니다. 

• Wave Compare Summary 에는 다음과 같은 정보가 포함됩니다. 

- <n> : 참조 파일(<reference_filename>) 에서 추가된 신호 수 

- <n> : 비교 파일(<compare_filename>) 에서 추가된 신호 수 

- <n> : 서로 다른 신호의 수 

7. Details 버튼을 클릭하면 다음과 같이 Compare Results 창이 표시됩니다. 

 모든 파형 비교 결과를 시간 순서대로 정렬하여 표시합니다 (예: 2000ns).  

 관심 있는 신호를 선택하여 Wave Window 에 로드한 후, 설계를 디버깅할 수 

있습니다. 
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13 Preferences 설정 방법 

 

Visualizer Debug Environment 에서 GUI 관련 기본 설정은 설치 디렉토리에 저장되며, 메인 창 및 

대부분의 서브 창에 대한 표시 특성(색상, 글꼴 등)에 영향을 줍니다. 

이러한 설정은 Preferences Manager 를 통해 변경할 수 있습니다. 

 

13.1 Preferences Manager 실행 방법 

 

Edit > Preferences… 를 선택하거나 단축키 Ctrl + N을 눌러 Preferences Manager dialog box 를 

열 수 있습니다. Preferences Manager창이 열려 있는 동안 메인 창에서 다른 작업이 불가능하며, OK 

또는 Cancel 을 눌러야만 종료됩니다. 

 

 

 

13.2 Preferences Manager Dialog Box 구성 

 

왼쪽 패널에는 설정 항목들이 그룹별로 정렬되어 있으며, 우측 패널에는 선택된 그룹에 해당하는 

세부 설정들이 표시됩니다. 

 

 그룹 이름 옆의 ▶기호를 클릭하면 하위 항목(예: Color, Font 등)이 확장되어 나타납니다. 

 대부분의 설정 그룹은 Color항목을 포함하며, 일부는 Font항목도 포함합니다. 
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13.3 Preferences 설정 항목 (Objects) 

 

Preferences Manager 에서 제공하는 설정 항목들은 다음과 같으며, 대부분의 그룹은 Color 설정만 

가능하고 일부 그룹은 Font또는 Array limit 설정이 가능합니다. 

 

Name of Grouped Preferences Description 

General GUI, 글꼴, 배경색 등의 전역 설정 

ATV Assertion Thread Viewer 창의 색상 설정 

Breakpoints 색상 설정만 가능 

Browse Menu 색상, 정렬 방식, 열 너비 및 메뉴 확장 제한 설정 

CallStack 색상 설정만 가능 

Class Instance 색상 및 Class Instance 표시 개수 제한 설정 

Classes 

색상 설정만 가능 Default 

Design 

Driver Receiver 색상 및 최대 Driver Receiver 개수 제한 설정 

Event Order 글꼴 설정만 가능 

FSM 
색상 설정만 가능 

Files 

LiveSim 
배열 수, 정적 멤버, DO 파일 실행, 세션 복원 시 동작, 

시뮬레이션 종료 후 명령 허용 설정 

Locals 
색상 설정만 가능 

Memory Usage 

Schematic 색상, 배경색 및 Cone flop, extend, 최대 조합 논리 수준 설정 

Search Design 색상, 자동 검색, 대소문자 구분, scope/검색 결과 수 제한 설정 

Search Files 색상 및 검색 결과 최대 개수 설정 

Sequence 색상 설정만 가능 

Signal Clipboard 색상 및 웨이브폼에 추가한 신호 자동 제거 설정 

Source Browser 
소스 표시 스타일 및 기능 설정 (텍스트 강조, 배경/글꼴, 실행 

추적 등 조정 가능) 

Startup 시작 시 창 복원 방식 설정 

Threads 색상 설정만 가능 

Transcript 색상 설정 및 컬러 코드 지원 

UVM Configuration/ 

Factory/Testbench 
색상 설정만 가능 

Variable 포트 아이콘 표시 및 변수 정렬 방식 설정 

Watch 색상 설정만 가능 

Waveform Wave 창의 색상/글꼴 및 표시-reload옵션 설정 
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14 Wave Window – Preferences 설정 방법 

 

Preferences Manager 의 Waveform 카테고리에서는 Wave창의 표시 방식, 신호 표현 형식 등을 

사용자 환경에 맞게 설정할 수 있습니다. 

Wave 창에서 Edit > Preferences… 메뉴를 선택하면 아래와 같이 설정 창이 열리며, 다양한 표시 

항목을 조정할 수 있습니다. 

 

 

 

주요 설정 항목은 다음과 같습니다. 

 

 Waveform 

- Grid, Value, Signal Height, Global, Timeline, Align Base Name 등 표시 여부 설정 

 Waveform > Color 

- Primary Cursor, Signal Name, Value, X Signal, Analog Signal 등 객체 별 색상 지정 

 Waveform > Font 

- 신호 이름 및 값에 적용될 글꼴 종류, 스타일, 크기 설정 

 


