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1. New Features
This document provides a high-level summary of this release.

It includes a summary of the new features in this release, any authorization code changes required,
any major installation changes, and any transitioning issues you should be aware of before installing.
Additionally, any last minute issues found in the final stages of testing are included.

For a detailed list of new features, refer to the Custom IC Design Release Notes available on Support
Center.

Multiple Tools...................................................................................................................................... 1-1
L-Edit.................................................................................................................................................... 1-2
Library Manager.................................................................................................................................. 1-5
Licensing..............................................................................................................................................1-5
S-Edit....................................................................................................................................................1-5

Multiple Tools

The following new features are available in this release for multiple tools in the Custom IC Design.

New Product Name

Starting with the 2024.3 release, all Tanner tools are now known as Custom IC Design tools. Significant
enhancements have been made in functionality, performance, usability, and interfaces to other Siemens
custom IC tools.

The individual tool names such as S-Edit, L-Edit, T-Spice, Library Manager, and Waveform Viewer remain
the same.

Siemens has foundry coverage for 266 PDKs from 41 different foundries with support down to the 12nm
FinFET node. The flow is extended to enable photonic design. The Custom IC Design ecosystem interfaces
with 21 other 3rd party EDA solutions.

Text Editors

The Text editor in the S-Edit tool and the L-Edit tool has the following improvements:

• Show/Hide Display Options — Toggle line numbers, white space characters, line endings, and word
wrap.

• Flexible Space Options — Convert tabs to spaces effortlessly and trim trailing and leading white
spaces.

• Advanced Regular Expression Search — Perform complex searches with an improved regex engine.

Multiple Tools
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• Search Settings — Control search with options for case sensitivity and whole-word matching.

• Bookmarking in Search — Bookmark search results for easier navigation and reference.

• Enhanced Code Folding and Bookmarking — Collapse or expand code sections, improved bookmark
functionality for navigation, and double-click to highlight all occurrences of the word.

• Zoom Functionality — Zoom in or out quickly using the mouse wheel or slider, providing flexibility for
various viewing preferences.

lib.defs Syntax Support

Library definition files (lib.defs) now support SOFTDEFINE, SOFTINCLUDE, UNDEFINE, and UNASSIGN.
Other enhancements include support for white spaces in paths and double hyphen (–) style comments.
There are also logging improvements for unsupported library attributes.

L-Edit

The following new features are available in this release of the L-Edit tool.

SDL/Interactive Router

A new SDL system is available in the L-Edit tool. The new SDL provides you greater flexibility and control
to drive layout creation from schematic source, and a comprehensive checking, reporting, and errors
resolving system to handle layout mismatches from schematic ECO (Engineering Change Orders).

The new SDL system allows you to:

• Generate all layout from schematic or pick-and-place selected component

• Correspond schematic and layout located from different library, named differently, or from mismatched
hierarchy

• Ignore device/parameter/pin when generating or checking layout

• Cross-probe between schematic and layout

• Display flylines

• Check and resolve mismatches between layout and schematic

A new Setup SDL page is available to allow specification of layout library search list, view search list, and
other SDL options/preferences.

A new SDL browser is available and displays a tree view of the logical design hierarchy and is the main
cockpit for SDL functionalities such as Generate All Layout, Pick-and-Place, Cross-probing, Show Flyline,
Device Mapping, and so forth.

L-Edit
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A new layout config view, and the Layout Config Editor, is available to facilitate advanced layout mapping
capability, and device specific overrides that is used to drive layout generation and layout checking (ECO) in
SDL.

Two docking windows for the ECO reporting system are available:

• SDL Differences window — Displays the mismatches between layout and current logic source. ECO
errors can be cross-probed to layout and schematic. ECO errors can be resolved by applying auto-fix
in layout, or mark as waived/ignored/manually fixed or back-annotation. ECO errors marked for back-
annotation will be used to update schematic (update parameters in schematic to match values in layout
or add device in schematic, mostly for dummy devices). This is useful is you want to keep layout and
schematic view in sync.

• SDL ECO window — Displays the differences between current logic source and previous logic source for
each ECO run. Current layout value is also listed as additional information. Past ECO run results will be
kept in the full report, but can be filtered out to just focus on the last run. It is useful to find out what has
been changed in the source side in between ECO runs.

The old SDL system will co-exist with the new SDL system to allow you time to migrate to the new system.
The SDL Navigator docking window, used in the previous SDL system, is renamed to CDI Navigator. The
previous/old SDL flow can be accessed from this docking window by manually importing a netlist.

A new interactive (manual) router is available in the L-Edit tool as part of the licensed SDL tool
capabilities. The Interactive Router utilizes PDK technology information along with the SDL connectivity
information from the schematic to assist the layout designer as they route each net to create DRC and LVS
correct layout. You draw the layout wire, cycling through the available layer stacks and place correct by
construction as you go, and you are warned of DRC violations as the cursor moves.

Dynamic flylines are displayed during routing to indicate the closest pin based upon net connectivity.
Features supported in the Interactive Router include sliding of current segment or via, auto complete of
route, and mirror routing. Wire models are supported to allow you to define custom constraints that can be
assigned to a net.

Integration for Digital Routing With Aprisa® — CDI (Custom Digital Implementor)

CDI (Custom Digital Implementer) is a user-friendly solution designed for small digital designs on mature
planar nodes, specifically targeting analog-on-top (big A, small D) mixed-signal ICs. Built on the Siemens
EDA platform, CDI integrates the Aprisa® tool for robust logic synthesis and digital place-and-route (P&R),
allowing users to execute synthesis only, P&R only, or both processes concurrently.

It supports up to 100k instances per token and can stack up to three tokens, accommodating up to 300k
instances to ensure scalability for various project sizes. CDI is integrated with the L-Edit tool, the custom
IC layout tool, facilitating a seamless RTL to GDS flow through a script-driven process complemented by
an intuitive GUI setup wizard. The setup wizard enables users to configure all necessary files for the flow,
including timing with SDC files, floorplanning, and power planning. CDI features a standalone GUI that is
user-friendly for analog designers who have limited experience with digital design. This GUI is similar to
the existing TDI (Tanner Digital Implementer) interface, allowing for an easy start and ensuring a smooth

L-Edit
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transition for current TDI users. It provides flexibility and ease-of-use, enhancing the efficiency of digital
implementation in mixed-signal IC design.

Port Enhancements

Electrical ports can now be viewed and edited similar to groups. With Individual Edit Mode on, objects
within a port can be edited similar to objects within a group. Ports have their own functions under the
Draw > Port Utilities for creating ports, adding objects to, detaching objects from, ungrouping, and more.
The Selection Manager is enhanced to support viewing all the objects contained within a port. With the
Individual Edit Mode (IEM) off, ports are shown as a tree. With IEM on, ports are shown as a list of
individual objects.

Enhanced Hide/Show by Object

The visibility settings are reorganized into two separate settings, one for the shapes (boxes, polygons,
wires, circles, labels, and persistent rulers), and one for collections (ports, instances, vias, groups, and new
non-collection object type that includes everything that is not a port/instance/via/group collection). This
allows you to have more control over what is visible in the layout window by separately controlling the
shapes that are visible while displaying only the types of collection they want to see. Quick access icons
are added to the bottom of the Layer palette to allow you to quickly turn on/off the visibility of each of the
shapes and collection types.

Array Splitting

You can now horizontally or vertically slice arrays along with other objects. Array elements that intersect
the slice line are assigned to the side of the slice line containing the greater portion of the element.

DRF Import

Layer color assignment in DRF is improved to use a more uniform distribution of colors from the DRF,
rather than just using the first ones in the list.

New Cursor Display

A new cursor option is available that displays both the smooth cursor and the snapped-to-grid cursor at the
same time. In the S-Edit tool, choose Setup > Technology > Schematic Grids. In the L-Edit tool, choose
Setup > Technology > Grid.

GDS/OASIS Import and Export
• A table of exported layers is included in the log file, including layer name, purpose, stream number, and

datatype. Layer color (locked and unlocked) and CUTSIZE are also included, if they are present.

• You can now map cellnames to OA cellnames in a case-insensitive manner during the import process.

• During import, a subset of cells can be specified. There is an option to import the hierarchy of the
imported cells. UPI and Tcl commands are also available to specify the list of cells to import.

L-Edit
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• For single cell export, the cellname can be renamed on export. Cells can be renamed on import. UPI and
Tcl commands are available to specify the cells to be renamed on export or import.

• Export can append to an existing file (GDS only).

• Importing a specific cell along with its hierarchy now handles previously unbound cells, ensuring
complete and correct data import.

• Logs and command line output now reflect the new Import/Export GDS options, ensuring that users can
easily track their actions and any changes made during the process.

Performance Improvements
• Significant performance improvements loading and closing OA databases from network file systems.

• Rendering performance of layout containing layers with thickness greater than one pixel is improved.

Other Enhancements

Hierarchical categories (category with type="category") are supported in the S-Edit and L-Edit tools.

Library Manager

The following new features are available in this release of the Library Manager tool.

• The tool now loads designs significantly faster.

• The tool now supports new view types, oaStdVia, oaCustomVia, WireModel, and WSP.

Licensing

The following new Licensing features are available in this release.

• The L-Edit station that the tool uses on start up can be configured from the Help > Setup Station
Configuration menu in the L-Edit, S-Edit, or Library Manager tools. The L-Edit tool must be restarted for
the new station to take effect. Station choices include: IC, FinFET, Mask, Photonics, MEMS, or Viewer.
The station may also be configured during program installation.

• Schematic, waveform, and layout viewers are no longer licensed. A current S-Edit license enables you to
open one or more of the schematic and waveform viewers. A current L-Edit license enables you to open
one or more layout viewers.

S-Edit

The following new features are available in this release of the S-Edit tool.

Library Manager
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Improved Rendering

Schematic and symbol rendering has been enhanced for improved quality and supports antialiasing and
user control of line thickness. Use the Tcl command, "setup render set -lineweight" to set the default line
thickness.

Dynamic Highlighting and Tooltips

Nets may now be highlighted dynamically by moving the mouse over the schematic. The net highlight is
rendered, and a tooltip displays showing the net name for the net currently under the mouse. Disjointed
clusters of the same net without a wire connection are displayed with arcs between each cluster. Tooltips
display with cell and instance names when moving the mouse over an instance, and with pin names and
types when moving the mouse over a pin. Turn dynamic highlighting on/off and control the detail level
using the Display Dynamic Info toolbar button.

Net Highlighting

Net highlighting is now available in new styles. The original "Highlight" style colors the wires on a net
with a different color. A new "Glow" style preserves the original color of the wires and displays a glowing
color around the net. A new "Thick" style preserves the original color of the wires and displays a solid color
around the net. Light and regular versions of each style are available to select how far the style extends
from the wires, and colors for all styles are user selectable for each net.

Net Labels, Text Labels, and Port Placement

Net labels and ports may be quickly placed by dragging a line. The tool places the net label/port at the
intersection of the line with wires and pins. When placing net labels, the intersections of ports are a
hotspot for placement. If the "Expand arrays" option is checked and the name field contains a list of names,
an array or a bundle, then each individual net or port name for the list, array, or bundle is sequentially
placed at each intersection when placing by line, or at each point when placing by clicking. The name field
is decremented as each label is placed. The Net Label, Port, Text Label, and Net Cap dialog boxes may be
hidden and restored with the F3 hotkey.

Instance Dialog Box

The Instance dialog box may now be hidden and restored with the F3 default hotkey to reduce obstruction
when placing instances. The Property Navigator is disabled while instancing, as the Instance dialog box is
the correct method to change properties of instances while they are being instanced the first time.

Enhanced Find

The Find capability is enhanced to fine instances based on instance properties and their values. Various
criteria are supported including less than, greater than, range, and so forth. Both evaluated and
unevaluated values can be searched as well as search by property name or description.

S-Edit
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Object Color and Thickness Override

Wires, graphics (paths, boxes, polygons, circles) and instances may now be assigned a color and thickness
override per object. Text labels, net labels, and ports may also be assigned an override color. Use the
Properties Navigator to assign the desired color or thickness. Select a net and a given color and thickness
by using the slow right-click on the net and invoke the Net Properties Navigator.

Override color and thickness of objects and nets are persistent and saved in the design database. This is
different from temporary highlighting such as using the Net Highlighting Navigator or when you select an
object. The object color uses the following precedent order from highest to lowest: selection color, net
highlight color, object color override, and default object color.

PDF Export

The S-Edit tool supports export to PDF. The options include the following: active view, active view and
hierarchy, selected views in Library Navigator, active library, or selected libraries in Library Navigator.

Only schematic and symbol views are exported. Other options include color or black and white, table of
contents, title page, footer, and scaling. Symbols in the PDF are hotlinks, and you can click on them to
jump to the corresponding schematic view. The Tcl command, "Export PDF", may be used for printing from
the Command window or scripts without using the GUI.

System Verilog Views

System Verilog views are supported and can be simulated using the Symphony Pro Mixed-Signal Platform.
The tool fully supports connectivity of System Verilog views within a schematic hierarchy.

SDE Setup Simulation Enhancements

Some Solido SE functions are now accessible directly from the S-Edit tool. This integration allows designers
to run nominal simulations repeatedly until the circuit performs as expected. Upon completion of the
simulation, you can review results, back-annotate currents and voltages, initiate cross-probing, and
troubleshoot issues. The functions are organized into three S-Edit toolbars:

• Run Simulation toolbar — This interactive toolbar provides functions to start and stop simulations as
well as to view progress and results. The Status button offers quick visual feedback indicating whether
results were found, if a simulation is in progress, or if it has completed or failed. A text field displays
the number of warning found during the simulation run and indicates whether these numbers have
changed since the previous run.

• Simulation Results toolbar — This toolbar facilitates cross-probing of voltage or current with the
Solido Waveform Analyzer. It includes functions for annotating currents, voltages, and OP small-signal
parameters from DC or transient runs, allowing users to easily access and view simulation results. An
Open Results button provides quick access to simulation output files and folders.

• Solido toolbar — This toolbar contains shortcuts for frequently used Solido DE functions, including the
Calculator, Solido DE Annotation Browser, Solido DE Database Browser, and options to change the plot
mode.

S-Edit
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These simulation toolbars are activated when a nominal test is open in Solido DE, but will not be activated
for PVT, Monte Carlo, or Variation Designer analysis.

A new docking station, Simulation Results, displays all scalar measurements from Solido DE's Outputs pane
in a tabular format. This view includes columns for name, value, change, and change percentage, with
highlighted scalars indicating whether they have passed or failed the specifications set in the Solido tool.

New Cursor Display

A new cursor option is available that displays both the smooth cursor and the snapped to grid cursor at the
same time.

Move Operation

There are now two ways to perform a move/edit in the S-Edit tool.

Inherited Connections

If you select an instance and dd a property with a type, NetSet, the Name field allows you to enter a name,
and also contains a dropdown field with possible values. The dropdown list contains available inherited
connections inside the selected instance.

A new Tcl command, inherited_connections, displays all inherited connections available at the current level
and also all instances at the current level that have NetSet properties for the inherited connections.

Design Check Improvements
• Custom design checks now return multiple results (and a mixture of errors and warning). Two new Tcl

functions are available:

design check -error <error text>

design check -warning <warning text>

When called from inside the per-view or per-cell validation functions (enabled by design check #5 and
#11, respectively), these create errors and warnings in a new pair of categories.

A user script, as shown below, creates three distinct entries in the Design Check Navigator. The final
"return" is the old method of creating a single error and is not required

proc IsValidView { DesignName CellName ViewName InterfaceViewName 
ViewType } {
   design check -warning "wArNiNg lcv = $DesignName/$CellName/$ViewName"
   design check -error "eRrOr lcv = $DesignName/$CellName/$ViewName"

S-Edit
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   return "failed = $DesignName/$CellName/$ViewName"
}

• Design Check for View and Hierarchy works for SDE mode.

• Design Check View and Hierarchy correctly uses Hierarchy Priority or config views, if specified.

HED Editing View List in Instance and Occurrence Tables

The inherited view list can be edited in both instance and tree views. The inherited view list can be
specified for each object to adjust the precedence in the view search order to determine which view to
use. A new "Set Rule" option is available from the right-click menu, and displays a dialog box allowing you
to set rules for occurrences, cells, or instances from a single interface. This feature supports both single
and multiple selections and provides a set View to Use and/or Inherited view list. The view list can be built
using the standard Edit View list editor in the tool, which ensures that the built view list only contains valid
views.

HED Cross Config Constraints

A redesigned hierarchy editor constants tool enables you to share constants across multiple configuration
views. You can set constants either locally or globally via the Setup > Preferences dialog box.
Local configuration views can override global constants. Global constants can be added manually or
automatically loaded from startup scripts using configuration Tcl commands.

Other Enhancements
• Ports are now auto-incremented when duplicating if the last character is an integer.

• When duplicating, a number is no longer added if the duplicated object has no number at the end.

• You can turn off auto-increment when duplicating items by choosing Setup > Preferences > Editing.

• The order of parameters in Setup > Simulation > Parameters can now be changed.

• The parameters in Setup > Simulation > Parameters can now be sorted in alphabetical order. Right-
click the pane and choose Reorder.

• The menu bar is now fixed in place and no longer moveable like toolbars.

• Hierarchical categories (Category with type="category") are supported in both the S-Edit tool and the
L-Edit tool.

• When generating a new Spice view with existing symbol/schematic, a template is now created with
the .subckt line automatically filled in with the pins.

• The version of Solido DE is now logged in the Command window and is written to the header of
simulation netlists, as a reference.

S-Edit
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2. Installation and Authorization Codes
The installation process consists of installing the Siemens Digital Industries Advanced Licensing
Technology (SALT), the license file, and the product software and documentation.

Authorization Codes............................................................................................................................ 2-1
SALT..................................................................................................................................................... 2-1

Authorization Codes

No changes to authorization codes are required for this release. You may request your existing
authorization codes by opening a non-technical Service Request on Support Center.

For additional information on licensing, refer to the Siemens Digital Industries Software Licensing Manual
for Siemens EDA Products manual.

SALT

Custom IC Design tools are currently installed with Siemens Advanced Licensing Technology (SALT) v2.1
and FlexNet v11.19.0.1.

For more information, refer to the following manuals:

• Siemens Digital Industries Software License Server Installation Instructions

• Siemens Digital Industries Software License Server Installer Release Notes

• Siemens Digital Industries Software Licensing Manual for Siemens EDA Products

• FlexNet Publisher License Administration Guide

Authorization Codes
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3. Support and General Information
Online help is available from technical support and documentation.

Global Customer Support and Success................................................................................................ 3-1
Documentation Access........................................................................................................................ 3-1
Broken Links in PDF Documentation - MG595892............................................................................... 3-2

Global Customer Support and Success

A support contract with Siemens Digital Industries Software is a valuable investment in your organization’s
success. With a support contract, you have 24/7 access to the comprehensive and personalized Support
Center portal.

Support Center features an extensive knowledge base to quickly troubleshoot issues by product and
version. You can also download the latest releases, access the most up-to-date documentation, and submit
a support case through a streamlined process.

https://support.sw.siemens.com

If your site is under a current support contract, but you do not have a Support Center login, register here:

https://support.sw.siemens.com/register

Documentation Access

Siemens Digital Industries Software product releases provide direct access to the documentation from the
cloud or locally from a documentation server.

You access the product documentation through one of these methods:

• Cloud-based documentation on Support Center through a documentation proxy — Uses the
Siemens Documentation Proxy that you install and set up on an internal network server to access the
product documentation on Support Center. Each customer site requires only one documentation proxy,
which multiple product installations can reference.

This option provides the following advantages:

◦ Does not require a Support Center account nor require you to log in.

◦ Eliminates the need to install and manage the product documentation within each installation.

◦ Always accesses the latest documentation for the specific release.

◦ Uses the same search engine as Support Center to search both HTML and PDF documentation.

Global Customer Support and Success
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◦ Accesses documentation in all translated languages if other than English is available.

For the Documentation Proxy downloads, go to https://support.sw.siemens.com/en-US/product/
266603595, click the Downloads tab, and select the latest version of the Documentation Proxy from
the dropdown list. Then, click the Documentation tab to access the installation instructions for the
Documentation Proxy.

• Locally installed documentation through the Siemens Documentation Server — Uses the Siemens
Documentation Server that you install and set up on your network or individual computer and
then download the specific documentation package from Support Center to access locally. Download
additional documentation packages for your specific release if other languages are available. This is
the required method if you have restricted networks that do not allow access to the internet. Each
customer site requires only one documentation server, which can be set up to support multiple product
installations and versions.

This option provides the following advantages:

◦ Provides the same navigational experience as viewing documentation on Support Center.

◦ Provides a central location to manage and serve the documentation within your site and restricted
network.

◦ Uses the same engine as Support Center to search both HTML and PDF documentation, including
each language that is downloaded, and uses the same documentation search index as Support
Center.

For the Siemens Documentation Server downloads, go to https://support.sw.siemens.com/en-US/
product/266603595, click the Downloads tab, and select the latest version of the Siemens
Documentation Server from the dropdown list. Then, click the Documentation tab to access the
installation instructions for the Siemens Documentation Server.

• Cloud-based documentation on Support Center — Accesses the documentation on Support Center
but requires an account and login in unless you save your credentials in the browser. This is the default
method if you do not set up a Siemens Documentation Proxy or Siemens Documentation Server.

Note
For instructions on how to set up the documentation access method, refer to Documentation Installation
in the Custom IC Design Administrator’s Guide.

Broken Links in PDF Documentation - MG595892

Due to enhanced security restrictions in web browser plug-ins used for viewing PDF files, manual-to-
manual links do not resolve. Clicking a link may result in no action, or it may load the title page of the
current PDF manual (instead of the target in the intended PDF manual).

The unresolved link behavior occurs in all web browsers on Windows® and Linux® platforms. This behavior
does not affect the links in the table of contents, the index, or the links to content within the same PDF
manual. Because of this behavior, the navigational experience of PDF manuals is compromised. However,
PDF is still ideal for printing. Siemens Digital Industries Software continues to monitor the situation and
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will adapt to future industry developments. For a fully-functional navigational experience, use the HTML
manuals.
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Third-Party Information
Details on open source and third-party software that may be included with this product are available in the
<your_software_installation_location>/legal directory.
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